Not able to identify an element inside Attach Window

Hi All,

I am getting the below issue and required your help to resolve it.

I used Chorme to download .nlph file and used start process to launch the application. After that I used Attach Window and inside the window I used click activity to click an element and all other required activity. Now when I run the process it goes to the Attach window and fail at the first activity as it is not able to identify the element and the Validate button shows in red color. Again if I to back to the application click on the application and come back and click on the validate button it again turn green.

Please let me know if anyone has the solution.


Use activate window activity once and try

Hello @Alom_R

Share the screenshot of the workflow which you have created and provide the error which you are getting.

So after downloading the file, you are opening the application, so once it opened all the actions need to be performed under an application scope.

So is that done? Also to make a window activie, you can use Activie window activity.

Hi @Alom_R

Seems the screen is in the background and the screen is not active, please make sure the screen is in the foreground, please try Activate Window Activity and then try click Activity.


Below are the screen shots

Launched Application

Attach Window selector

Activity failed

Selector failed

Same selector showing as green on validating

Please let me know how to proceed further.

I used Activate window but didn’t work out.

Hi @Alom_R

Since the Navigator Tab is Opened, the Switch Responsibility icon is not validated and the Click Activity is failing, try clicking on the page before clicking on the Responsibility Icon, or you can close the Navigator tab and then Click on the Icon.


Already tried, no luck.