Assignment2- Generate Yearly Report for Vendor add queue item issue


#1

Hi guys!

I’m testing the dispatcher’s process workflow, and I am stuck with the “Add Queue Item”, because it keeps throwing exception “Orchestrator information is not available. Please check if UiPath Robot is started!”
image

I looked through posts related to this exception, and none of them worked for me. I tried to start the UiRobot.exe with privileged rights. I also tried to start the UiRobotSvc Service, but I could not find it in the service list.

Is it because I am not the administrator of my laptop, so I do not have privilege to run the robot service? Or is it because I need to set up a robot in the Orchestrator? Do I need a license code to do so?

Thanks a lot guys!


#2

I had this issue to, here is what worked for me.

  1. Run UIRobot.exe like you said
  2. Log into Orchestrator and Provision a robot for your machine
  3. In the system tray, click on the UI Icon image
  4. Click Settings on the window that comes up
    image
  5. Enter information from your provisioned robot and click connect
    image
  6. After this, you should be able to see the robot in Orchestrator as Available

#3

OMG! It works!! Thank you sooo much!!


#4

it works, thank you


#5

Hi,
Can you help? I am trying to add the argument WIID to the queue for type=WI4 and status=open.
But confused with the code.


#6

Hi @Aishwarya28
I also have the same problem . Can you share the xaml so that I can understand my mistakes?


#7

Would request you to share your xaml file so that I can check it. I have now completed advanced level with 100/100. :slight_smile:


#8

Hi @Aishwarya28

congratulations. Actually I can understand that you have cleared level 3 by your tag " robot master":grinning

I have started with dispatcher and getting the error in getTransactionData.xaml file GetTransactionData.xaml (19.2 KB)

please help me to solve this.


#9

Hi Atul,
First of all, you need to make the selector for elementexist dynamic as stated in walkthrough.

Secondly, it seems you have merged gettransactiondata.xaml code… I can see mention of WIList in your code which is part of assignment 1. Please delete this.


#10

It should look like this:


#11

Thanks @Aishwarya28
Actually I know about the selector but my main concern was about this validation error.
Thanks for your help.
I will remove it and try to run the code.


#12

Sure. Do let us know if you still find error.


#13

HI Aishawarya
I have error as “process finished due to no more transaction data.”
I followed many links get it resolved but still facing the same issue. please check my workflows amd let me know the mistakes.
Process.xaml (17.1 KB)
GetTransactionData.xaml (15.1 KB)
I think it is not moving to the next page. please tell me the corrections.


#14