Add queue item: Orchestrator information is not available. Please check if UiPath Robot Service is started

Hi,

I am using Studio 2019.2.0 CE. I am working on assignment 2 of the Advanced Developer Course.

I get the following error in the dispatcher process “Add queue item: Orchestrator information is not available. Please check if UiPath Robot Service is started.”.

Do I need to publish the dispatcher process and associate the package to a robot service to be able to push the workitems to an Orchestrator queue. I have already created an empty queue and referenced in the config file as mentioned in the walkthrough document. However I get the above mentioned error when I run the .xaml file from studio.

Thanks

Have you connected the local machine robot with the orchestrator? In orchestrator, under robots, does your current robot show as available? and also make sure, that your local machine’s robot service is running…

Does it help?

I get the same error even if I connect to the Orchestrator service from the local m/c using UI Robot . if you meant I ll have to publish and deploy the .xaml file to the orchestrator and associate the corresponding package to a robot job, I am yet to try that out. Would these steps be required though to use a storage iem such as a queue. For the 1st assignment, I used Orchestrator assets for credentials without having to do any of these steps. Would help If I receive step-by-step instructions.

1 Like

Hi… nope… you dont need to publish the packages to use orchestrator assets or queues. That error usually occur when the robot of your local machine is not connected to the orchestrator. For now, could you share two screenshots…

  1. In local robot, go to settings and show me what it shows… you can access this from the bottom right hand side toolbox of your taskbar… if its not there, search for uipath robot in start menu and run it… then it should show up there
  2. In orchestrator robot page, show me what it shows there…
1 Like


There is a default M/C name . However , I need to supply the Orchestrator URL and Machine Key to connect which I have tried and yet gives me the same error even after a successful connection.

Thanks

Right now, why do you have those fields empty and status = offline? Once it is configured, it should always get connected…

Machine name in orchestrator should also be the same name as your computer name. Can you show me the machine info in orchestrator, and also the robot info in orchestrator?

Hi i am also getting the same kind of issues using trial community version, i am able to add machine, robot in orchestrator but robot is showing ‘offline’ in the system tray. i tried finding the robot service in my machine but it is not available. can you please help me in getting it setup? screenshots of my orchestrator and UIRobot from system tray as attached.

image

Hi @Nilanshu_Soni,

Can you share the below screen with me?
Under Robots screen


Check the two highlighted. UiPath Orchestrator Machine Name should be same your computer machine name
Username here should be the same username you use to login to your computer

Under Machines


Machine name should be same as your computer machine name. and use a standard machine

If you share it, I can guide you through

How can I connect the local machine robot with the orchestrator?

Hi @ROBERT_RUSSELL_MONSA

You can refer to this link

1 Like