Assignment1 - Get security hash. Error at main.xaml

orchestrator
activities
studio

#1

Hi,

I have done all the points in this exercise that is about setting the settings up. When I run the main workflow I get an error message (see attachment). But when I run all the Workflows one by one manually the work fine. Please help me understand this problem.

Regards,
Mikael

mainError


#2

You will have to find which workflow is causing the problem you can do it by using Log Message activity. Error means after attaching the browser particular element on which you have write the activity can not be found.

Use log message activity this will help you to pin point the location of the issue


#3

I have tried to put the log message activity on the places i could think of were the problem could be, but come up with nothing…


#4

Make sure you have used Wild Cards in the selector of attach browser, that might be causing problems here I guess!
Tell me if that helps :slight_smile:


#5

Hi @Niket_Ghai,

I have tried to use the whild card in selector in both ways, the way like in the attachment and then in both ways the robot is going a little further but give this to errors (see attachment) an they are both according to the main file. Can you please help?


#6

It is open ACME and login in to it and goes to Work Items get all the WI5 rows, then it close the window and open it again and do the same thing and then opens sha1 online and closes IE windows and give those messages

Regards,
Mikael


#7

Your actual problem is there is not data to process. that means you must have called ExtractWIItems workflow in InitState and passed the WIList in GetTransactionData.xaml that part is not working properly


#8

here is a ss from my GetTransactionData.xaml.


#9

Put a write line activity on the top and verify the count of in_WIList like -

in_WIList.Count.ToString


#10

Did you mean like this?

It does the same even now…


#11

in_WIList.Count.ToString and see the count in output pane


#12

gives me this error

image


#13

Great, this means the argument what you are passing from InitState does not have any value. Check where you have extracted the WIItems and then verify the same thing that you did here. If the data was scrapped properly and have items pas that variable to GetTransactionData as IN argument


#14

here is my extract_data file.

Should I change my out_TransactionData to an in argument?


#15

Hey!
Try printing the data table using output data table activity…I guess there is some problem in Data Scraping…


#16

Assign your Out_WiList argument to a local variable in Main.xaml say WIList variable of type DataRow[]. After this when you call GetTransactionData.xaml pas this as an In Argument to that workflow as in_WIList.

But before all this please check that WIList has values by writing WIList.Count.ToString in a message box or Write Line activity


#17

There was a problem with the Data Scraping but when I did the Scraping again it worked. It goes through all the data and pages but the data table is still empty… I here something wrong?

I also assigned out_WIList argument to WIList variable in the main.


#18

That’s great now pass this WIList variable as an IN argument for GetTransactionData like in_WIList


#19

Here is my GetTransactionData.xaml did you mean that here i should edit theargument? or did you mean in the main?


#20

I meant in main workflow like this -