App/Web Recorder Targeting Precision Issue

Hi,

I’m following the Introduction to User Interface Automation, and I’
m trying to work along with the App/Web Recorder. My issue is that the recorder does not seem to be able to target smaller fields, I need to save a file and it will not allow me to select “File”, but it will go on to select the entire taskbar. I tried to create the selection field manually by holding the left click on my mouse and create an area over “File”, which seems to be working. BUT when I enter another action it gives me an error message.

It seems to be app related. I played around with it on Chrome and it was very precise.

Hi,

Try changing selection method and try to indicate again
Refer to the image
Capture

Hello @sebastiano_santini

Please try to move the mouse pointer around the file button. Then it will allow to select the button alone instead of the taskbar.

Also, did it ask to choose the screen as the first step of recording?

I tried changing the settings, it still doesn’t select it.

Hi,

I did select the NotePad as the application. I try to move it around the File, but it still selects the entire taskbar… I don’t know what the problem is because it does select all the “objects” on the page…

Hi,

Refer to workflow below

Sequence.xaml (19.9 KB)

Hi, thanks for replaying and for all the content attached. It still doesn’t work, the robot is not able to identify the “file” as a single ui element. It is a problem that i have found only with the notepad, as of now. I overcome it by simply using the Ctrl+S, but still it is quite annoying that i cannot get it to work.

I also tried to use the Image selector, which works for getting to click on File, but leads to a fail when it closes the drop window and can’t press Save.

Hi,

Have you tried with send hotkey activity ?