Not recording/capturing sub-elements (eg menus, folders, etc)


#1

Hi! I’m very new to UiPath, and I’m currently on lesson 4, but found an issue.

When I’m recording I can’t capture any small elements - it just captures a big region, whatever the “mode”.
For example, I open Notepad and enter some text but then I can’t select any tab from menu (File/Edit/Format/…). It just captures the whole window. Same happens with everything else that is “small”, such as folders on file explorer, URL bar in browser, calculator buttons (it just selects the whole calculator window)… Selecting and highlighting on UiExplorer doesn’t work either.

It captures either this:


or this:

Thanks! :slight_smile:

Studio/Robot/Orchestrator Version:

Last stable version: 2016.2.6379
OS Version: Win 10.0.14393


#3

This does happen from time time. I presume you have tried closing UiPath, restarting machine etc?

How are you accessing the application? is it on a local machine, or a VDI perhaps. I have just checked and using Basic Recording you should be able to individually identify each of the File menu buttons.

The main text window, however, will only identify as one element.

RD


#4

Thanks for your reply richarddenton!
Yes. I have tried closing UiPath and I also reinstalled it three times. As well as my machine. I’m working on a simple laptop, local machine. I can’t identify any menu buttons… :frowning:


#5

3 days have passed and it’s working now. However, I did nothing to solve it, it started working randomly, so… I still don’t know the cause. Which is annoying.