Alert from Outlook sending an email

email
activities
smtp

#1

Hi everyone, I developed a bot on a custromer’s PDL, running on a VM, that have to send an email at the end of process, but when the activity sendOutlookEmail is performed I get a pop alert from Outlook saying “A program is trying to access e-mail addresses […]”. I think this is can be resolve with an firewall, but the customer, for security issues, can’t install this. There ia another way to resolve it? It is possible to use STMP for sending outlook email?

Thanks in advance!

Capture


#2

Hi, I think that you should try to use the Exchange activities.

Send Exchange Mail Message is what you need.


#3

Just put a click on activity to check and click on concent/approve if that window appears.


#4

I never used this activity. Can you tell me please which parameters are mandatory?


#5

The “approve” button can be clicked only by an human, and this make lost sense to automation…


#6

Check with your IT admin to remove that validation on the PCs running UIpath robots. We did it in my company.


#7

You do need some additional parameters if you plan on using this activity, mainly a set of valid credentials and the Exchange server (these should be stored in the Orchestrator as Assets).

You can find out what your exchange server is by using the following steps: https://social.technet.microsoft.com/Forums/Azure/en-US/715a9f6d-6259-4163-abf6-1e1c9afdf580/locating-existing-ms-exchange-server-name?forum=exchange2010

Or you can simply ask an IT admin.

The upside is that you do not rely on Outlook so your going to get a much more robust and reliable workflow.


#8

i did it, but they answer me that they can’t because of security


#9

I find out the exchange server, but I get this messagge:

Immagine

This is the workflow:Prova email.xaml (10.3 KB)

Thank you very much to help me!


#10

Your exchange server parameter is the problem. I do not think you are using the correct server value.

The Exchange Server should be an URI, since your value does not respect this format, you’re getting an exception.
Basically, your Server value should contain the protocol prefix in the beginning like https:// .

You can probably ask your IT for the exchange server


#11

Or use another robot executed every 2 minutes to check if there is any window with that selector and click on it if any.


#12

Hi,
You need to change one setting in Outlook.

Follow below steps:

Go to >> “File>Option>Trust center” in Outlook.
Right Side window, Click “Trust Center Settings…” button.
Left Side Window, Click “Programming Access
Check “Never warn me about suspicious activity

Save the changes, Now you will not get this Popup again.


#13

Hi Santan, thank you for your repling. I tried this solution but is not possible change this setting because of security rules of my customer.


#14

@Siltra:
This is normal issue which we face every now and then as maximum time clients are not giving us right to change the setting.
For this issue use image exist activity to check this prompt. Select the check box and from drop-down option choose 10 minutes so that your BOT execution will not get interrupted.

Other option is:

Use IMAP or SMTP protocol option to configure Gmail or any other mail service which client uses.


#15

Hi,

i’m tryning an SMTP protocolo and customer give me this information:

-Port
-Server (IP address)
-Email
-Password

But I get this error:

image

Any idea? I set the secure connection to “Auto”


#16

Hi Siltra.
I have came across this security pop up when using get outlook email. Try using parallel activity. On the left side you can have the outlook interaction activity and on the right side check with element exist for the security pop up and handle it with ui automation.


#17

this seems a great idea!