After several days works loop, workflow suddenly could not communicate with IE

Hi,

I have a workflow, that is working with IE, in loop model for attended robot. It was working fine for several days, but one day it suddenly stopped and says Cannot communicate with Internet Explorer browser. Since the robot was stopped, I then tried to open the Internet Explorer browser manually but also failed.

At first, I thought the problem was with Windows. But I discovered that after I killed all the UiPath services, the IE browser can be opened again manually. I restarted the UiPath robot services again and started the workflow, it ran.

Changing browser to another is not an option since I worked with a legacy web pages that were incompatible with the current browser such as Chrome, Firefox, or even Edge.

I have followed the setting instruction in this page https://docs.uipath.com/studio/docs/internet-explorer-x64 , set the required pages to trusted sites… but the issue is still there.

Is there suggestion or anything that I could do to solve this issue? Thank you in advance.

Regards,
Tony

@beantony

Please check below thread and try with all approaches. May be anyone will help you.

Cannot communicate with Internet Explorer Browser - Troubleshoot steps

1 Like

Hi, thanks for the insight… yes, I’ve tried all the methods. Those troubleshoot methods are fix for those who can’t communicate with IE at all. It’s similar, but different.

The problem is that the workflow works fine in first two or three days, but it suddenly got stuck until we restarted the UiPath services. After restarting the services, it can run for another two or three days before it get stuck again.

@beantony

May i know which version of IE are you using ?

it’s the IE 11 with update version 11.0.33

1 Like

Is any antivirus blocking the application or server and also ensure once that site is added to trusted site list in IE
Kindly restart the machine once and try again

Cheers @beantony

hi, thank you for another suggestion…

the only working antivirus is windows defender, which shouldn’t be an issue. I’ve worked with another workflow that loops, but with firefox, in the same machine and it doesn’t have issue even after running for weeks. But again, this legacy pages only works with IE, so I couldn’t do it with Firefox.

The sites that I’ve been working with has been added to trusted list and IE compatibility mode list.