Advanced Training: Getting zero items in array after extracting work item data table

I am stuck on the Calculate Client Security Hash walk-through from the Advanced Developer Training. I realize there are several other posts that are somewhat related to my issue, but I still can’t figure out what I am missing…

When I run the bot from Main, the number of items in the array returns “0” which means there is no more transaction data to process and the bot closes down. I verified that I am getting the data table (with “output data table” activity + write line to display), but after assigning to the data row array, the count always returns “0”.

In System1_Extract_WorkItems I am outputting the scraped data table to the argument out_DataTable.

From the Main workflow- as part of the Init state as described in the walk-through where we get the work items- I am binding the out argument to the local variable dt_WIls.

Then I am immediately assigning the DataRow array variable WIList as follows:


As you can see, I am using a message box to print the count of the array which is returning “0”. What am I doing wrong with the array “WIList”? Thank you all in advance.

Hi @bsylvester,

Can you use write line and see how many rows you have in dtWls by using dtWls.rows.count.tostring

Before that have you resetted your data in acme , I mean do you have WI5 items with status as open

Thanks @anil5. I am pretty sure there were W15 items with open status but I reset the data on this run (see page 1 of results below). Used Write Line to get number of rows in the extracted data table dtWIls and I got 81- but still 0 items in the array WIList. Thoughts on what to try next?

Hi @bsylvester,

If you see in ur select statement you have used W15 but you have to use Wl5, it’s not 1 in WI5 , copy from the website and put in select statement


@anil5 - I can’t believe it was that simple :slight_smile:. The issue was that I was using the number “1” instead of the letter “I”. It works now.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.