Adding a process to UiPath Agent/Robot

A few questions about adding processes to an attended robot:

  1. Where does UiRobot/UiPath Agent store the .nupkg packages for the processes shown in Process list?
  2. Is it possible to publish to the UiPath Agent process directory as a Custom Publish Location from UiPath Studio?
  3. Is it even possible to add processes to an attended robot without Orchestrator?
1 Like

Fine let’s got one by one
For this

We can find the nupkg files in
“C:\ProgramData\UiPath\Projects”.

Then

  1. create a project in uipath studio
  2. publish the project to a directory of choice
  3. copy the .nupkg package to the robot machine in the default package directory
    ( in my case thats in C:\ProgramData\UiPath\Packages\ ). please check your path
  4. after this you should see the project in your robot (tray). Y

And then finally for this

We cannot start a process from Orchestrator on this type of Robots, and they cannot run under a locked screen. They can be started only from the Robot tray or from the Command Prompt . Attended Robots should only run under human supervision

Hope this would help you
Cheers @manderss

2 Likes

This directory does exist on my computer, but it doesn’t contain any of the processes available on the robots process list.

The install location of UiPath on my machine is:
C:\Users[username]\AppData\Local\UiPath

There is a “packages” directory in there, but it only contains packages for default UiPath activities and none of the processes available to the robot.

One step further into this directory we have:
C:\Users[username]\AppData\Local\UiPath\app-19.8.0

Which I suppose is the latest version, this also contains a Packages directory. Once again I’m out of luck, only default UiPath Activities in there.

I am aware of the use cases for an attended robot, but previously the only way I have been able to get my processes added to the robots process list is by publishing my processes to Orchestrator and then download them from there to the robot.

1 Like

yah its hidden one (ProgramData)
we need to type it manually in file path bar
kindly try and let know for any queries or clarification @manderss

Cheers

1 Like


I maneuvered into this directory, added the .nupkg for my new process in there. As you can see in the picture, the processes available to the robot are not in there and the one I added does not show up in the robot process list.

This picture shows the packages folder within the UiPath installation directory:


Once again, none of the processes available to the robot are in there.

And one step further into the installation path:

None of the robots processes are available there either.

The processes that are available to the robot in both pictures were downloaded to the robot from Orchestrator, but I want to know how to add the processes manually from the desktop into the Available Process list.

Fine
to be very simple
–once your process is ready in uipath studio - publish it
–we dont need even a orchestrator to be connected
–once after we publish the package we can see that package in this folder
C:/ProgramData/UiPath/Pacakges
–and mean while when we open the robot tray we can see the published package in the tray

this worked for me as i reproduced now
hope this would help you
Cheers @manderss

1 Like

To be clear:

  • I reproduced all of these steps before you made this post.
  • I have the latest updates to UiPath 2019.8, if that makes any difference
  • See previous posts for more info.

Cheers @Palaniyappan

Does anyone with the current version of the UiPath Platform installed have this issue? If so, how did you solve it?

I have finally solved this issue, the problem was that my robot was connected to Orchestrator. Once I disconnected it I could get processes from local .nupkg files.

Thats what already suggested right
fine
@manderss

1 Like

There’s a huge difference between not needing to be connected to Orchestrator and must be disconnected from Orchestrator, which was the case here.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.