Add data row error lambda expression

Hello everyone…
My bot was running fine before. I updated UiPath to newer version 2022.10.1(community).

Now it’s giving me error in “Add Data Row” like

error BC32043: Too many type arguments to ‘Func(Of Out TResult)’. error BC36625: Lambda expression cannot be converted to ‘Expression(Of Func)’ because ‘Expression(Of Func)’ is not a delegate type.

Can any1 please help!!

Thanks in advance!

Hello @shesherao.patil - Try to import System.Linq from imports panel and see how it goes


Hi, I have the same problem. I needed to add a value into array row and get this errror, when I delete the variable, it starts to work again. Weirdly enough I can add as many empty or hardcoded strings and it still works but when I add a variable it shows the error. Import of Linq didn’t help. Seems like the ArrayRow can handle only so many variables.

welcome to the forum

may we ask you to which languague the project is set, C#?

Hi, it’s VB I believe

Getting the same error even when I try to initialize an array outside of add datarow activity

I also got the same error after converting my Windows-Legacy project to Windows with the new update. My Add Data Row activity worked fine before converting. The array row I wish to add has 19 elements, but the error disappears if I only keep 16. Import of System.Linq did not work for me also, and I have tried initializing as New Object before the Array Row entry. Hoping to follow to see how any solutions are achieved.

I think the updated version is not suitable for add data row hence try to Install Previous Version 2022.4.4 it will work.


I am actually using 2022.4.3. Can we count that it will be fixed in the next version?

Thank you for this bug report (I moved it to the feedback section for better tracking).

I confirmed the same behaviour on my own installation and recorded this as a bug for our team to have a look at.

1 Like

How can I fix this error?

I have 7 Assign step using string.format() to assign value to a text template, but just 2 step been report error BC32043 & BC36625

I am also facing same issue. Did you find solution for this?

I’ve the same issue!! Did you find any solution?!

I solved this issue by dividing array to two smaller arrays, then concatenating smaller arrays into final big array which will work fine in “Add Data Row” activity.

no! I don’t kown what had happen!

I try to find the rule ,but it happen in the No.17 argument. and another fomat with 107 argument is ok !

When you update to new version,
While you open the project shows the pop up at the top,
Do not Click Convert to windows.

So sad ! I had covered to new vision

Could you please send the xaml.