Wrong cursor position when in VPN

Hi everyone!

So, I’m building some robots at work and everything was going fine.
Today, out of the blue, some of the selectors stopped working but in a strange way: when the robot tried to click on a ‘Save’ button, the cursor went to the left of the button (10cm-ish) but in Studio the ‘Highlight’ option was still showing the right location.
Every other selector was fine, only when it had to click a ‘Save’ button there were problems. After disconnecting from the VPN, it all worked again.

There are no errors/exceptions from Studio since it believes that the button has been clicked, so no useful log whatsoever: the only exceptions are thrown when the subsequent activity can’t work properly since the previous one hasn’t really been executed.

This is a very concerning problem for me since some of the robots have to be connected to that VPN. Any idea of what might cause the problem/solutions?

Thanks in advance!


Is there a chance that the scaling options changed system wide?

I don’t think so, the connection consists in a password put into a client. I can see no settings changed in any way

It is quite tricky. I would suggest contacting our support (if you happen to own the Enterprise license).

Otherwise, we would need to dig deeper into what has changed for the project to break.

Were there any changes to the activity packages versions or your project? If not, were there any windows updates/group policy changes introduced on the robot machine?

I opened a ticket with the technical support but I want to say this here too.
When I commit the changes I made to the project on Sourcetree, even when I just open the project without changing anything, I notice some changes in this string:

sap: VirtualizedContainerService.HintSize= ********* (the *** are numbers that change autonomously)

Turns out (thanks to technical support) that by using ‘middle mouse button’ instead of ‘left mb’ the issue is solved!

Also thanks to @loginerror for the help!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.