Workday application - Click button no longer working

I have been running a bot consistently for a few weeks via StudioX on the Workday application, however, the click buttons are now no longer working. I keep getting the error where it can not find the button on the interface I instructed the bot to click. Has anyone else encountered this issue or know of a workaround? Seems like the keyboard shortcuts are not working either.



If the selectors got changed you will face the issue

Remap the selectors and try

Hope this helps you


I tried multiple times but still no luck. I tried image selection as well and nothing.

Were you able to fix this? We are having similar issues.

If I remember correctly, this error occurred after a Workday vendor update was applied where the search bar was enhanced to have recent searches appear below it automatically upon a user beginning to type into the field. I believe the issue I had was not that the Click activity was not working, but that the Type Into activity was not. The activity card target had to be updated to reference the search bar with the previous search recommendations appearing below it in order for it to register.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.