@Windows UAC prompt


#1

Hi @badita, @aksh1yadav @vvaidya

Scenario:

I need to type user name and password in User Account Control Window. I am doing it in citrix enviroment, recorder will stop automatically when the pop up displayed.
PFA.

How can I type user name and password in the UAC window in citrix enviroment?
I tried with find image it doesn’t work, could please help me on this?

Thanks,
Girish


UAC(User Account Control)
#2

How About HotKeys

Image Exists = true

TypeInto

Tab

TypeInto

Enter (or Click Yes Image)


#3

Hi Vinay,

I can’t use image exists and type into or hot keys since citrix recorder will stop once this pop up window appears. Once this window appears all functions will be disabled.

Thanks
Girish


#4

Lets see your workflow.


#5

I’m a little confused - you said it’s in Citrix environment (which I understood as robot is running on local machine and has an active RDP[or equivalent] connection to a remote one). If that’s the case, it shouldn’t matter what pops up on the remote machine.

What action prompts the UAC?


#6

Hi Kniola,

I am trying to open “Services.msc” in my citrix desktop it will popup User Account Control Window.

Thanks
Girish


#7

But shouldn’t it popup on the “other side” of the connection (and thus you could handle it with image automation)? :confused:

Either way - depending on your system, you might try this (not tested) and make the robot run the shortcut:
http://www.winhelponline.com/blog/run-programs-elevated-without-getting-the-uac-prompt/

Or any of the solutions that are around the net for “run mmc as admin without UAC”, as this is nothing UiPath specific.

One other possible solution:
Create a shortcut for target “C:\Windows\System32\runas.exe /user:domain\username C:\Windows\System32\mmc.exe”, then TypeInto the password to the console that will popup (possible Yes confirmation needed in between).


#8

Hi Vinay,

Try opening service.msc in ur local treat your local as citrix. Enter the credentials in User Account Control pop up.

Thanks,
Girish


#9

Already tried It doesn’t ask me for credentials, just permission Yes or No , mostly I’m the administrator on the remote machine.


#10

Hi Vinay,

Please try to enable UAC, may be in your system it is disabled.
Please refer below link to enbale
https://support.microsoft.com/en-us/help/17228/windows-protect-my-pc-from-viruses

Thanks,
Girish


How to due with the security pop up? Need urgent help
#11

Of the services