Input credentials into User Access Control

I have a scenario where I need to open task manager. As this is a Office system, We need to input the user credentials in User access control window(For reference, UAC window will be throughout the screen and not like any small pop-up. Mine is Windows 10 OS).

Please help me on how can I give credentials and open task manager.

Note: Not using Orchestrator.

1 Like

Buddy you can either use
Windows credential manager or just a type into activity with the user credentials…
For more info kindly have a view on this buddy

https://www.uipath.com/kb-articles/how-to-work-with-windows-credentials?hs_amp=true

Cheers @rameshgp43

I tried with type into activity and its not working…it is unable to type the text…throwing timeout exceeded exception.

I am not using Orchestrator…so, I cannot use any credential activities.

Kindly let me know for any other alternative

1 Like

kindly enable these properties in type into activity buddy
–simulate type
–clickbeforetyping
–emptyfield
and make sure the selector is valid and you can see that by clicking on … in selector properties in type into activity
Cheers @rameshgp43

We can’t capture selectors from the user Access control page. As I mentioned , mine is windows 10. when UAC window is displayed, the whole background will be blurred off without access to any of the applications on main screen/desktop screen.

And I tried with simulate click and window message along with the points mentioned by you…but no luck

Fine buddy
Then try with send hot key activity with key tab
use this activity until the tab key takes you to the field where you want to type the credentials you want to
Cheers @rameshgp43

were you able to enter now buddy @rameshgp43

As soon as the UAC window is opened, focus is already on the password text box where I need to type.

On clicking task manager, UAC window will open. Without doing anything, we can directly enter the password and click enter.

Problem is with only typing the text and clicking enter.

All the uipath tools like explorer, screen indicate etc. are not working on UAC window.

@rameshgp43

I guess this screen is coming foreground right. Generally when this kind of screen occurs we can’t work with other screens without closing that one. I guess we can’t handle this kind of things with UIpath.

@Pablito

Is it possible to handle this kind of issue with UIpath ?

Fantastic buddy @rameshgp43
–as you say the focus is getting set on the password text box where you need to type,
lets do one thing
–use a set to clipboard activity, and pass the input with the credentials you have as input text in string type
–Then use a send hot key with keys ctrl+v, that would paste the text which is there in the clipboard.to the password text box

Kindly try this and let know buddy
Cheers @rameshgp43

Like we used to say: “Sky is the limit!” :slight_smile:
There is a way to open apps without UAC prompt. Please have a look here:

Eventually PowerShell can be very helpful as we can open application from it with elevated privileges and put credentials directly to the command like it’s described here:

2 Likes