Windows Scheduler on VM

robot
error
schedule

#1

We have been working on a robot for 6 months.
We want to deliver the robot … but it does not work with Windows Scheduler !

  • Windows Scheduler is used to start the robot on the VM
  • this works fine if we are attached to the VM with an RDP session
  • when we are not attached with RDP, the Scheduler does not run

In the Windows Session command line we have tried using the flag --monitor.
When the flag --monitor is used, the robot does run through the scheduler …
… but the robot is ineffective … it fails to recognise many screen objects.

Surely we cannot be the only project running a robot through Windows Scheduler on a VM ?

Has anyone else had similar problems ?

Hugh


#2

Hi,

Are you saying it doesn’t even start or is the problem that it fails to find elements?

You can also possibly check Windows Event Viewer to get clearer information on the Exceptions that were thrown.

If your problem is that elements are not being found, it could be a desktop resolution issue.Things to consider:

  • on Windows Server 2012 after a user is logged out completely the Start Screen shows up instead of the Desktop which cause a timeout to occur; consult your Server Admin to change the settings so the Start Screen does not show up (psst. there is a way to adjust the registry to fix it)
  • Try using Launch Workflow Interactive to kick off your job. This allows you to set the resolution and depth settings (probably 1920x1080 32depth)

Regards.


#3

Thanks Clayton … I omitted some important details

  • we are using a Windows 7 VM
  • we are using Scheduler from withing Windows 7
  • when we schedule a robot we get the error 0x1 (that’s the error from windows scheduler)

We have tried various hacks … but we cannot run our robot through windows scheduler … now we can’t be the people to try to run a robot from scheduler ? … can we ??


#4

Thanks ClaytonM. The issue is obscure. The robot runs with the scheduler but we get strange results when not run when we watch the screen. So we schedule. We disconnect. We wait. Then we get the email with stats to say not so good. I thing it could be: Corrupt VM? Legacy issue (the robot is running an old app)? Coding? It’s almost to say that the legacy app is not happy running in disconnected mode. I’m sure the answer is simple but we are old guys trying to make things work and it’s important to us. Thank you again ClaytonM.