Running on virtual machine (robot don't see UI)

Hi here.
I’m have some problem.

This is case:

  1. Virtual machine with Studio
  2. Robot develop on VM by rdp connection from my pc
  3. Robot running on VM

it’s not matter kind of robot start up - from studio (standart or debug mode), from robot interface on VM, from orchestrator CE - if i connected to VM by rdp and have full-size rdp-window - it’s run ok, not any kind of errors. If i’m not connected to vm or rdp-window is minimazed - robot don’t see UI. He run ok blocks just like “open application” or “send outlook email” - blocks, what don’t use UI. But in block “type into” with “waitForReady”=“complete” he doesn’t see UI and it’s end of timeout.

Settings for minimaze rdp-window and for robot runs is ok on VM.

What i must to do?

1 Like

Hi @Nikolay_Burykin,

Try using the back ground automation properties.(Eg: Simulate Click, Send Window Message etc).

Let us know if it works :smiley:



It’s not problem to try, but i need a time for this.

But some question before: block just like “get full text” don’t have this setting. Will it works? Or i should use another activity?

Yes, it’s works.
It’s my fault of forgot to do this? I mean - it’s a normal way and standart setting in develop robot for running on virtual machine?

But it’s another problem - result of work is different time to time and different to start up from rdp-window and wacthing for process

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.