Windows/Cross Platform published processes don't work yield error on UiPath Assistant

When we are creating a new process, we see three options
Windows - :x:
Cross Platform - :x:
Windows Legacy - :white_check_mark:

I don’t want to use Windows Legacy because it will be phased out

The other two options are executing the process in my setup.
I publish a test process on the orchestrator and execute it on my virtual machine
Error comes in the assistant
Could not find a part of the path ‘[…]\project.json’.


Hi @Sarmad_Nadeem ,

Could you pls check whether you are able access the project.json file from your machine which you are trying to run the process via assistant. And also could you refer the below link for further assistance.


The directories are completely changed and the json file is located somewhere else. This is the reason why I can’t execute the process. But I do want to know the workaround/solution.

Are you able to locate the project files in your local. If so There is one thing we can do for now is delete the json file and try to open the process by using main.xaml so that it will automatically create json file. So once the json file got created publish process and try to run from assistant.

If still not working there is Solution like do some settings available in the above link I shared. Please review. Thanks.


@Sarmad_Nadeem Did you find any solution? I’m facing the same issue when I publish a Cross Platform UiPath Project Orchestrator is trying to execute like a Legacy Project.

I spoke with UiPath about it.
They are telling me that the Legacy Projects will not be outdated soon. It will take a while. So you can deploy a process in legacy and use it.
But sooner or later you will have to migrate all your processes to Cross-platform projects which can be executed in the newest version of Robots.
Hope this answers all your concerns.

I Fix the problem by updating the UiPath version, this is the UiPath screenshot where I saw the solution