Where exactly do I invoke the Data from the level 3 assignment?

activities
studio
training
academy
reframework

#1

In the guide it says:

Open the Main workflow and expand the Init state by double clicking it.
o On the Entry region, locate where the KillAllProcesses workflow is invoked.
o Add a new sequence after the Invoke KillAllProcesses activity to read the input transactions data table.
o Inside this sequence, invoke four of the previously created workflows, as follows:
:black_small_square: System1 Login
:black_small_square: System1 Navigate to Work Item
:black_small_square: System1 Extract Work Item Data Table
:black_small_square: System1 Close

And now I got a question. I have already invoked the System1 Login in the InitApplications file. But this invoke is placed after the sequence “if first run”. The KillAllProcesses activity is also placed inside the sequence. So where exactly should I place the files to Navigate to Work Items and Extract Work Item Data Table?

Logically it seems it should be placed after the InitApplications because this is the first time we open the browser and the pages


A problem with getting credentials, 1st assignment, Advanced Training
#2

@MGMKLML

yes i understood ur prob, they say create sequence and once seq is created with work flow like

:black_small_square: System1 Login
:black_small_square: System1 Navigate to Work Item
:black_small_square: System1 Extract Work Item Data Table
:black_small_square: System1 Clos

after that again Initallapplications workflow will be ter right…?


#3

@phyogananda Yes but this is wrong as InitAllApplications contains invokes “System1 Login” and “SHA1OnlineOpen”. What’s the point of invoking it again then?

Could you please also tell me what type does the WIs variable have? This is the variable where you assign the datatable.Select(). It must be DataRow[], isn’t it?


#4

@MGMKLML

thats wer my workflow is stuck and i am getting that error,

i dint get time to look, i will update once i fix it and get some solution

you let me know if it works for you


#5

@phyogananda, I solved it just by following a simple logic. Their guide can be confusing sometimes which is maybe intentional.


#6

what did u update…?


#7

@phyogananda, I remained it that the InitAllApplications file contains log in to both websites and then I added navigate to work items and extract data afterwards. So I didn’t put it after KillAllProcesses, it is simply wrong.


#8

Hey @phyogananda, actually as per PDD document, Navigate to Work Items and all other workflows except close System1 and SHA1Online should be invoked in Process.xaml… This is what I did and its worked perfectly. Also InitAllApplication and Close System1 should be disable in Init State in Main.xaml.

Thank You,
Navneet


#9

@NavneetPanpaliya

i will try and let me see what happens


#10

New_Assignment1 (3).zip (2.3 MB)

Hi @NavneetPanpaliya

I have completed the workflow, but I am facing an error like Transactionitem cannot be null.

it works good till data scrapping, but after that it will go to gettransaction data workflow, form there it will throw error message and execution will stop.

thank you


#11

Hey @phyogananda, I corrected most of your workflows so the error is gone, but you need to correct ‘extract client details’ workflow. It seems ClientID, ClientName and ClientCountry are not getting set so correct it first and pass it to SHA1 Online as input value to get Hash result. Attache is the updated file.

Regards,
Navneet

New_Assignment1.zip (2.3 MB)


#12

@NavneetPanpaliya

thank you very much, I will check and update