Where does "Transaction video snapshot is not supported." log come from?

I don’t know what happened, did I accidently press some shortcut or what, but for some reason one of my projects has started to log “Transaction video snapshot is not supported.” after a transaction has been processed (Successful, BRE or Exception).

And only this certain project, not the others. This log appears if I run in in debug or publish it to Orchestrator and run in another server. So it seems it’s a project specific setting, maybe? I coudn’t find anything related to this from project.json or from the project settings from Studio or from one of the folders starting with . (.project, .settings etc).

It seems to come from SetTransactionStatus.xaml. I tried to replace SetTransactionStatus.xaml from another project, but this log still keeps coming.

Anyone knows where does this come from and how can I set it off?

image

image

This error typically occurs when trying to capture a screenshot or video of a specific UI element in a remote session, such as Citrix.
Is ur process running in any such server
@EevaHanninen

No, it’s not running in Citrix.

And it’s weird that this log appears when transactions is processed as Successful, there’s no error, screenshot is not taken, but still this log appears in the end.

1 Like

Hi @EevaHanninen ,

Could you maybe perform the process execution in Debug Mode and also perform Step Into action one by one, so that each step is understood and validated, mostly from your statements you could apply Breakpoint to the activity which is at the end in the Process workflow and then Perform the Step Into action from that point onwards.

Thanks for the hint, I tried it.

From the detailed logging you can see it appears when calling the UiPath.Core.Activities.SetTransactionStatus activity. Nothing special in the implementation here, basic settings are used.

image

I’m using the same queue when debugging or running in test server btw, but the queue does not have any setting related to this. On the test server I run the process on different account (not my own as I do when debugging).

I know there is this Enable recording setting in Orchestrator for the process (Additional settings of the process), but I don’t have this on when running the process on test server. Could it somehow be related to this anyway, Transaction video snapshot sounds about the same what this setting does.

image

1 Like

It could be something with queue recording
Check the settings here for more details.

QRec

for Video recording and/or Recording failed queue transactions

Cheers @EevaHanninen

I’m using on-premise Orchestrator, queue recording is not enabled.

Edit: I also tried creating a new queue, but same result, that log still appears.

1 Like

That’s the option I find like something needs to be validated
If we are getting the error still would recommend to reach UiPath support on this

Cheers @supermanPunch

I also saw this in our Log messages popping up since yesterday.
I think it might have something to do with the package version of UiPath.System.Activities (or UiPath.UIAutomation.Activities)? We have one project with version 23.10.2 (System) and 23.10.3 (UIA) and that one is giving us the Log message (Level: Warn). All other projects are still running with versions 23.4.x without such Log.

At least the runs are not affected by this message and it’s also not showing up in the Alerts or in the emails from Orchestrator.

1 Like

I am also getting the same message after I updated my packages to the latest version. This is generating extra log messages to the database. Anyone found the solution?

Thanks @Juli! Seems that the package update is the reason for these logs as @Mateus_Oliveira also got the same logs after updating. Solution migth be to downgrade to a previous version or wait for hotfix.

Same here
I am also unable to capture the snapshot

Hi,

any update how to solve this issue?

downgrade is not an option. this issue makes our team frustrated because this hidden makes our error test scenario fail.

alternative solution: we pause using the latest version 23.10 to new project until this issue sort out

Cheers,
Indra

Hi,

I tried downgrading the package to version 23.4 but I keep getting the same error and sometimes the screenshot fails.