Weird error Job stopped with an unexpected exit code: 0xC000041D

Hi all and I hope you a good day!

Unfortunately, the error below keep coming out when running automation involving huge amount of repetition of certain process.

  1. Read data (one time only) from excel
  2. Do automation based on input data from excel

I’ve already add kill process for the excel.exe and replaced the new excel file with the same content from the old excel file. The error keep coming out…Anyone know what going on or if you have any suggestion to solve this error??

Thank you :slight_smile:

image

Hi @chakri

you can share your xaml if you want to easily address the issue.

cheers :smiley:

Happy learning :smiley:

1 Like

unfortunately i cant share the workflow as it against company policy. But basically I only use read range for excel and do automation using for each loop of the excel data.

Thats all, nothing much but below is the version of the activity package I’ve used.

Hi @chakri

Could you try introducing a small delay (1s) between reading the data and processing it? Just as a test if it would stop the error from occurring.

Also, there are two read range activities - one for the Excel Application Scope and one that can work without it. Could you specify which one causes the error (and maybe try with the other one)?

Lastly, could you check your project on a light version of your source Excel file (new file with little data) just to see if it is not causing the issue in itself.

1 Like

Hi, I already tried both ways to read the excel file (with Excel Application Scope and without). This error happens when around 150th automation run. However, with small data there is no issue but when it reaching around 100+ of data, the error will appear.

Then I decided to NOT use any excel related activity, the input data (excel file) I’ve converted to text file and use for each loop for every line. The error still occurred when it reached 100+.

Is using try-catch the only possible way to solve this issue? I hope the exception handling can resume the for each loop when exception happen.

Edit: will try to add delay and see how it goes

Thanks and regards,
Chakri

Is there any chance you can create a new project that reproduces the issue but doesn’t contain any sensitive information you would not be able to share? It would help a lot if I could run the project on my machine to see if it also reproduces for me.

Hi all,

This issues kinda solved I guess. Here’s what I did:

  1. Uninstall and re-install Uipath Community.

  2. Increase WCF size : Job stopped due to unexpected process termination - Troubleshoot Steps

  3. Change read input data method from Exel to other method without using any excel related activity for dealing with exception 0xE0434352

  4. Remove Log message fields and append line activity for logging. Maybe this causes WCF message size more than 1MB? See: WCF Message Size Configuration

  5. Finally, long-time pending Windows 10 update.

Hope it helps!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.