Wait For Download Grabs Temp File


I’m running into an issue with the “Wait For Download” activity, where, instead of grabbing the downloaded file, it grabs the .tmp file. When it comes time to use the downloaded file, StudioX can’t find it because it’s trying to find the .tmp file instead of the actual downloaded file.

I tried building a delay into the “Wait For Download” activity to see if that’d resolve it, but so far it has not.

Any other solutions y’all aware of?

1 Like

Hello @Garrett_Mindrup!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

I am having this same problem, were you able to find a solution?

Same issue here. It’s random, but definitely defeats the purpose of using Wait For Download.

I have the same problem

can you please give more details?
On the wait for download activity you have a Timeout to configure, default is 300seconds, does your download takes longer?
Also you have the option to exclude some temporary file extensions.
Can you try these please?

I have reviewed the Execution.log information when the process was to download 16 files, it only downloaded 15, I searched for “message”:“Wait for Download Closed” and in one of them I get: “Wait for Download”,“State”:" Closed",“Variables”:{“fileDownloaded”:“e37d13c7-123f-451a-9ad9-f3f0dae537a0.tmp”," when in all the others I get the extension .txt

Set the time to be 120 seconds, default is 30 seconds. But the download randomly fails even before 120 seconds. What I have noticed is that it fails more at higher bandwidths, that is, I tried on a network with a bandwidth of 140 Mbps and it seems to fail more continuously. On the other hand, I tried on a 16 Mbps network and it seems that it fails less. I’ll do some tests raising the time out to 5 minutes.

Among the files the heaviest is one that weighs 208MB but it failed in the one that weighs 98MB

The activity looks for any file to be downloaded, and the temporary file that a browser creates before a download is complete makes the activity think the download is complete.

The activity needs to have a property where we can tell it the filename we are waiting for.

Although it’s very simple to write a Do While that does this.

you have the option to exclude the temporary files or any other extension you define

1 Like

The file name comes with a timestamp.


I also did a do while that counts the txt before pressing the download button, once the count is different it continues.

In this case, a similar problem also occurs, and the page hangs “do while” left in an infinite loop. Just yesterday I tried that, in most of it it works for me and in certain cases it fails me, I would like to put a timer on my “do while”.

How to exclude specific file endings? Can this be done in Studio as well?

No we do not. These are the only options we have for this activity.

I am having the same problem using StudioX. Sometimes the name of the downloaded file is saved properly for use later on in the process, other times it saves the tmp file name causing the process to error later on. There are limited options in the StudioX properties to do as earlier suggested.

The “Wait for download” activity fails at seemingly random points since a .tmp file will sometimes satisfy the “download complete” condition instead of waiting for it to be converted to its final format. I am attempting to download individual small .xlsx files (5KB - 3MB) and the activity will sometimes fail within the first 10 seconds (well within the set timeout of 300 seconds), so their size is clearly not the problem nor should be the bandwidth or timeout settings.

Just write your own with a Do While, using File.Exists in the condition.

Hey @serge.r

The activity has been improved in the latest release which overcomes this scenario.

You can say to activity which extension files to be ignored.



22.4.x has it. 21.10.x doesn’t seems to be! Thanks for the tip!

1 Like