VM Browser Issue

Been running the same workflows for 2 years now all fine until recently,

All of a sudden started getting lots of retries, checked the process on a local machine all was fine.

Logged into a VM when the process was running and it looks like the bot is performing the actions but nothing shows in the browser its blank.
Fortunately, the process fails before it gets to a critical step and then retries.

Going in and clearing browsing history seemed to make a difference and could get some up and running. But one I had got working has gone back to the original state of not showing anything in the browser.

I have updated the process to the latest versions of everything and updated chrome, the bots everything.

I have 4 bots running when I should have 9 for a process that usually takes 3hours Im looking at 6 atm.

Any ideas?

Hello @rmorgan

Is it a background automation? Is it failing at some particular activity?

Thanks

Its an unattended bot that interacts with Chrome to pay fees on a website

It fails, becasue of one of the interactions its trying to perform can’t be found which is fine.
But the reason it can’t be found is that its like the webpage isn’t loading If i log onto a VM Chrome is blank but you can see the mouse moving etc

If I run the same process on my machine all is fine webpage loads as it should.

Was it working earlier and you were able to see the webpage opened?

Is there any recent update happened to the chrome version?

I’ve just updated Chrome, but

If I start the bot off and immediately go into the VM and see the page loaded then it will carry on all fine.
But I ran the same process yesterday and it was fine

Does that mean if you are not login to VM the execution is failing at some steps?

Can you check whether its failing for some click or type activity and you have enable simulate Clikc\Type for that?

Its not the bot workflow, i have it running now on limited VM’s fine

On other VMS when looking at the VM when its running the web page isn’t loading causing it to fail, and I don’t know why the page isn’t loading on one and not the other.

All VMS are exactly the same.

please make sure application it has been updated or not, updating applications also cause of this issue and you can open browser in incognito mode if you dont want save history

First thing I did, just doesn’t make sense :frowning: