Virtual Machine Kicking Me Off When I Run Robot From Orchestrator

orchestrator

#1

This might be a silly question, but we just got up and running with Orchestrator and we were testing robots yesterday and ran into something strange… So I was able to provision and have my local machine’s robot run a job from Orchestrator on my machine no problem. However when I put 2 VM robots in the same environment so all 3 would run the same job (message box that says “Hello World!”) I was not able to log into the VMs and watch the robots execute since it seemed to kick me out of the VM when the robot tried to run. Now I was logged in with the same domain/username and password the robot was using to log into the VM, but in the Orchestrator training he demos something very similar and is able to watch the robots on the VMs execute. Has anyone else ran into a similar issue or maybe I am just missing something silly? The VM robots were trying to use a package that was published by my local machine but shouldn’t multiple robots be able to run processes that they didn’t publish?


#2

I encountered the same issue when running on a robot on a VM and the issue appeared to be related to the VM not allowing the same user to be logged on more than once at a time and the reason it kicks you out of the VM is because when creating the robot you need to enter the windows credentials for the VM which the robot uses to log into the VM in order to run a job. I presume there could be some settings you could change for the VM to stop this happening.


#3

Thanks so much for your quick reply Benocon, that gives me something to look into. I will talk to the folks who set up the VM and see if that’s a setting they can change.


#4

Just don’t have them set multiple sessions limit because what that will do is allow multiple sessions per user in parallel, meaning that if a session is active and you log on with that same username, it will create a new session and you can’t get into the active one until it is disconnected. But, maybe there are some benefits to that; to me, it’s very annoying :wink:

A few things I would suggest looking at is in the UiPath.Settings file, located in C:\ProgramData, check if “LogonToConsole” is false, which you want.

Also, if your VM only allows up to 2 active users logged in, you would want them to activate the Remote Licensing Server I believe, which let’s more than 2 users log in at once. Usually, Orchestrator will tell you that “resource is in use” if this setting is not activated.

Another thing is if you use the Invoke Interactive activity to call your workflow, it will kick you out when it starts.

Typically, if it kicks you out you can still log back into your user account while it’s running to watch it, however, don’t click minimize or exit which will disconnect and stop your process.

Regards.


#5

@ClaytonM @cvent978 @Benocon @ovi @andrzej.kniola @aksh1yadav @ddpadil

Hi,

Can any of you specify the settings so that I can prevent getting kicked out of the VM when the job is started from the Orchestrator?


#6

Hey @praveen_yarlagadda, I think it’s the LogonToConsole setting. Check the UiPath.settings file on the server being run on located at C:\ProgramData\UiPath and make sure that setting is “false”. Also, if you use Launch Workflow Interactive, then uncheck LogonToConsole. If that doesn’t help, then I’m not sure.

Regards,


#7

Also make sure that you’re not using same account credentials as the robot, otherwise he needs to take over your session to start.


#8

Followed the steps mentioned by @ClaytonM it worked for me. Thank you. I did followings:
I go to the VM, then to C:\ProgramData\UiPath\UiPath.settings
and change “LoginToConsole”=False. Make sure you restart the UiRobotService. After that once job is run from Orchestrator, your current session wont get disconnected and result will appear in same session.
image


#9

I tried changing the uipath.setting file and restarting UIRobot again. still it doesn’t work. Is there any other solution which can prevent getting kicked out of the VM