VB6 Application | Selectors

selector

#1

I have a old VB6 application that I’m trying to get elements from. Few issues I have

  1. When I use GetText activity and select the field - it highlights complete application, not just the field. For this matter, only certain section of the app does this - others are selectable.
  2. If I use Find Image activity, and I highlight the image I want, it comes back to UiPath Studio empty. Nothing selected, same with Image Exists. Just empty with exclamation point stating it’s missing.
  3. If I start with “Screen Scraping” and I select the area, it comes back empty again.

Now, some fields in the application are selectable (like I said), some not by clicking on the application and some by clicking the application, but instead using UiPath Explorer and manually drilling on the visual tree, starting with application we need.

I can’t share the application screens because it’s proprietary, but wanted to see if anyone else had this issue and how they fixed it. I’m stuck at this point, because option I had in my back packet was OCR and it’s not working.

I’m using 2018.1 and have tried it with 2018.2 as well. Any help would be greatly appreciated.


#2

Have you tried with the recording tool ? Is not citrix but using citrix recording maybe could work.


#3

Nothing works - Citrix Recording, as you click through or screen scrape, once you are done and go back to Visual Studio, it’s empty (like as if you didn’t do anything).


#4

If I use “Attach WIndow” and I “Indicate” my VB6 app, it comes back empty. Then I retry by indicating something else, like IE browser, it works … then I try again to change it from IE to VB6 app, nothing - it keeps IE as my attached window.

It’s like it does not exist.

NOTE: it does highlight the app when I select “indicate” but when I click to select it - nothing happens.