GetText activity doesn't work in old windows application

Dear all,

I used GetText activity to get text from an old windows application where the selector is as below :


but it returns an empty string.

Is there any other way to solve this ?

Thanks for your feedback


is UIPath and the application one you are trying to automate both are in same machine or in different machine ?

Hi @albel,

is there any way to get rid of the IDX attribute in the selector?
Check with the UiExplorer if there are more attributes you can use to make the selector better.

Actually, they are in the same machine.


Use UIExplorer and change the selector and try it.

Hi @FrankSchikora

There is no other attribute that the one in the selector. I tried via UiExplorer but seems the same.

I tried also “Get Attribute” activity but it returned an error :

Get Attribute ‘TWINDOW1’: Attribute not supported by the current UiNode.

Are you trying to get text from any elenment …? Or its a free text ( element here my meaning is button , text box etc)

Hi @vinay_reddy
My app is windows app based on a french IDE NatStart which is C++ based code generation. My window (a dummy one for test purpose) looks like this :

Each of the fields has a selector with idx number (1, 2, …) as stated in the first sending. What ever is the field when I trying gettext it returns empty string.

Seems UiPath cannot recognize all windows applications.

Can you try with screen scraping to extract the values and if that doesn’t work give a try with computer vision activities

1 Like

Hi @anil5
I tried Screen Scraping and it works. Thanks. In summary I’m going to use “Get Visible text” activity. In the other hand, for check boxes and radio buttons the method it’s not working. So I wonder how can I solve this.
But still want to understand why selector for windows app didn’t work .


If I see the selector there is no unique element or attribute that is representing the fields from where u want to extract and you can never depend on idx because idx changes often, this happens with some applications in that scenario we have to use the other best methods suitable for our process

Do you have any suggestion for the checkbox and radio button ?

the check box always you will select the first one only or it differs

So u can try this, when you launch the application where is the cursor and use a single type into and provide multiple tabs to reach check box and radio button and press enter.

I didn’t catch up. My intention is just want to know if the ckeckbox is checked or not (kind of true false output). I don’t want to enter any thing on it.

Is get attribute activity not working for these 2, give a try

Hi @anil5,
I tried Get Attribute and doesn’t work either. It always returns false no matter it is checked or not


This is really annoying. any other idea ?

Hi @albel,

Only select the check box and use aastate attribute which gives true or false.

I tried to do so but I cannot only select the checkbox alone. it comes with the text.

So did you use the aastate attribute and any luck with that, if not while indicating the screen use f3 which allows you select the region of check box and give a try.

Hi @anil5

I managed to pick up only the checkbox :
whether is checked or not, “aastate” return “focusable”