Value cannot be null. (Parameter 'version) - package management issue

Hi
I’ve searched the forum and found similar issues, but I’m unable to resolve it.

We get the error
image
when we try to publish a process to Orchestrator.
In that process we have a package that uses UiPathCodedWorkflows 23.10.1.
Then we have another pakcage that use UiPath.System.Activities 23.10.5.
UiPath.System.Activities 23.10.5 is dependent on UiPathCodedWorkflows 23.10.3.
So when we upgrade to UiPathCodedWorkflows 23.10.3 we get the error message: Value cannot be null. (Parameter ‘version’)
UiPathCodedWorkflows 23.10.1 is fine - we can publish.
UiPathCodedWorkflows 23.10.2 generates the Value cannot be null error
UiPathCodedWorkflows 23.10.3 generates the Value cannot be null error
UiPathCodedWorkflows 23.10.4 generates the Value cannot be null error

Here’s our packages from UiPath:
image

Does anyone know how we can fix this?

It seems like you are encountering a version compatibility issue between UiPathCodedWorkflows and UiPath.System.Activities in your packages. When upgrading UiPathCodedWorkflows to versions 23.10.2 and above, you’re getting a “Value cannot be null” error.

One approach to resolve this issue is to check the dependencies specified in your project files (e.g., project.json) for both packages. Ensure that the versions specified for UiPathCodedWorkflows and UiPath.System.Activities are compatible.

If UiPath.System.Activities 23.10.5 has a dependency on UiPathCodedWorkflows 23.10.3, make sure your project references both packages with compatible versions. For example, your project file might look like this:

"dependencies": {
  "UiPathCodedWorkflows": "23.10.3",
  "UiPath.System.Activities": "23.10.5"
}

If you’re using UiPath Studio, you can manage dependencies through the Manage Packages window to ensure that the versions specified are compatible with each other. Also, make sure that you have the correct versions specified in your Orchestrator environment.

In some cases, it might be necessary to consult UiPath documentation or support for specific version compatibility information or consider reaching out to UiPath forums for community assistance. Always check the release notes for each package version to identify breaking changes or required adjustments when upgrading.

Hi @Larss

Try updating all the package to latest version by keeping Runtime rule as Lowest as Applicable. For Coded Workflow dependency reduce the version number and save all the dependency. This should solve your problem.

Hope it helps!!