User License Management and Unattended robots in 21.4

I am bit confused with User License Management Functionality. Consider I have enabled it and my user is able to connect Studio/Assistant using Interactive-Sign in. Now if I have another user in the same tenant who needs to connect an Unattended Robot, how do I use Machine Key? User License Management Functionality mandates interactive sign-in and my assistant stays “Connected, Unlicensed” as its using machine key.

How do I achieve the below with User License Management Functionality enabled?

  1. Attended/Studio - User Mode - Interactive Sign-in
  2. Unattended - Service Mode - Machine Key

Hi @JithinKP
Firstly, You need to disable "User License Management " in Organization Settings of Admin tab as image below.

You can see “Disable” red button, you just click on that button, and “Enable” button will show up.

After that, you go back to security tab before. All checkboxes enabled and uncheck “Enforce user authentication, disable robot key authentication” checkbox and click "Save’. And now, you can create machine, robot and connect UiPath assistant to Orchestrator with machine key.

Status will turn to licensed.

Hi @Songoku_ichi_2907 - Thank you for the response. Yes, I can do that but then I won’t be able to manage the user licensing outside Tenants. It’s like going back to old license management inside the Tenant. What could be the purpose of this feature if I can’t use both attended and unattended at the same time in a single Orchestrator?

@JithinKP - You absolutely can connect Attended robot and Unattended robot to Orchestrator at the same time. Now I create two robots one is attended robot and one is unattended robot.

In “License” tab at tenant level, I am using one attended robot and one unattended robot connected to a single orchestrator named “enterprise 01” at the same time. You can see two license status of robots activated. That means two robots connected to orchestrator successfully.

Why can I do this. Firstly, you need to allocate license to tenant.

And then you need to set number of attended robots and/or unattended robots can be used.

As below, my two robots connected to a single orchestrator.

Hi @Songoku_ichi_2907 - I think my question was misleading. I am not trying to connect Attended and Unattended with User License Management disabled. I am trying to connect attended and unattended with User License Management enabled. If an organization has this feature enabled in Orchestrator how can they connect Unattended Robots? I don’t want to disable the feature.

Hi @JithinKP , It was really my misleading :grinning:
I think, we just can use unattended robots with machine key by unchecking the “enforce sign in” from Tenant . If we enabled “User License Management” and check “enforce sign in”. It looks like you should try to sign In to your Orchestrator instead of using the machine key. Right now the robot is actually in a monitoring state, so we cannot run any processes from assistant interface.
But you can run process in orchestrator even though this state is connected and unlicensed, as soon as you trigger a process through orchestrator it will pick it up and execute.

@Songoku_ichi_2907 - That’s my confusion actually why would UiPath bring up this feature. If a client purchase Automation Cloud now, this feature is enabled by default. Disabling the feature and going back to old model for unattended robots doesn’t make sense.
Connected, Unlicensed and expecting the process to get executed during trigger is not the ideal way I feel. We won’t be able to use Studio with Unattended for debugging purpose also. Documentation clearly says, it’s recommended to use Unattended robots with Machine key. All these are contradicting now and I m not sure whether we are missing something.
We have received this query from one of our client who has NFR cloud license. Have to tell them to disable the feature for now I guess.

1 Like

I am not even getting that Disable button option.

Any idea pls share

HI , I am also facing same issue . Cannot even see disable button rather it is a delete button over there . Were you able to find a solution?

No. Haven’t found solution yet.

I guess User License Management do not have a Disable option in Community Cloud. Created a community cloud account now, option was not available. Requested an Enterprise Trial on the same account and it became available.