Robot unlicensed when using machine key

Hi,
I’m using the latest community edition. The robot is showing as licensed when using service url but showing unlicensed when using machine key. The only reason why I switched to machine key is the fact that I can’t get the unattended bot up an running. The jobs stay in status “pending” for ever. I read in the forum here, that there might be a bug with the service url and therefore I tried to connect using the machine key.
Currently without success. Any idea what might be wrong?
Machine name in Orchestrator is set to my machine name from “cmd hostname”. The machine in orchestrator has the unattended license assigned. Not sure what else I should/could verify.

Thanks in advance
Ronny

I too got the same error.

THE license allocation for community edition - orchestrator includes -

  • 1 unattended robot license available

2 Licenses for attended - named user + 2 License for RPA Developer pro (both attended robots)


(This licenses allocation can be changed in the Automation cloud page.)

I changed the robot to UNATTENDED and then changed the security settings in the Tenant.

Please view the below link for further information as when we will get: “CONNECTED, UNLICENSED”

so if both the options selected, it can throw an error ,
image

so please check the security settings after allocating proper robot as per the licenses

Thanks for your response, sri24.

Two “strange” things.

  1. Connection via machine key works from another machine as expected.
  2. Shown security settings are both enabled but greyed out. So I can’t change them with my admin account. From what those options say, I’d need to disable the second one.

Hi please check if the sign in option is enabled in your uipath assistant.
If you are both signing into the platform and using machine key it shows unlicensed.
please sign out if you are signed in your assistant

It’s not a case of over utilization of the license. Even if no machine is connected the “problematic” one shows “Connected, unlicensed” after reconnecting.
Also the license utilization in “Tenant” → “License” shows the the license is used/assigned. Furthermore under “Tenant” → “Robots” → “Unattended Sessions” the license is assigned to the machine which says “Unlicensed”. Could this be a client issue as it works on another machine?



Please check the type of robot displayed in the uipath studio when u open.
unattended license i.e unattended robots are not fixed.they will be used as per how we have assigned the robot type.

1.try disconnecting from uipath
2.delete the machine and configure it again with the robot in the orchestrator.
3.then try reconnecting from uipath assistant
4.check the above license type displayed

hope it helps…
I checked all the robot types in each modern folder and changed its type to unattended.

Hi sri24,

ok, it works on the “Connected, unlicensed” machine when I login in UIPath Studio too.
I’d expect that it should also work without logged in UIPath Studio but this might be due to the enforced authentication.

image

Any idea why I’m not allowed to change these options?

Hello @roerle

I’m having the exact same issue as well. Connected and unlicensed. And the two options are greyed out. Any help to overcome this would be much appreciated.

Thanks

Hey there.

I sort of found the solution to this problem. I was having the exact same issue. Connected and Unlicensed. And my options in the security tab were greyed out. Turns out you just have to click sign-in, in uipath path assitant and it will change to Connected and Licensed. I suggest to re-sign in on uipath assistant when encountering the issue Connected and Unlicensed.

Hope it helps. :wink:

I was having the same issue and did what Kamlesh_Bogun suggested. The Assistant is now showing “Connected, Licensed” as expected, but I came across another issue. When I run a bot, everything goes fine until it needs to, for example, retrieve assets from Orchestrator. In that case, it throws the following error: Get Credential: You are not authenticated! Error code: 0
The only way to stop getting this error was to force-change the security setting and unchecking Enforce user authentication, disable robot key authentication. Both options are greyed out so I need to first change the Run disconnected hours options, save, and then uncheck the option. After a day or so, this option appears checked again.
Any idea as to why this is happening?! Thanks in advanced!

2 Likes