Updated UiPath and now get error "Could not find a part of the path"

Hi @MW23

Could you try this solution, if possible?

Please report back :slight_smile:

1 Like

Thank you all for your replies! I really appreciate it.

Unfortunately, none of the suggestions have resolved the problem. So…I decided to completely uninstall UiPath and then install it again (using the UiPath Platform Installer 19.4.2.0).
Now, i get another error message when I try to run a small sample process:

19.4.2+Branch.master.Sha.e17a3bedca2a7da0d0b716b5f8f765d1d5ef1ddc

Message: Access to the path ‘[…]project.json’ is denied.

Exception Type: System.Exception

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:

System.Exception: Access to the path ‘[…]\project.json’ is denied.

Seems like some access issue. But what i don’t get: i have used the same network and pc before and everything worked fine. My rights have been extended and i have installed a newer version of UiPath…but these are the only changes i have made…

Any suggestions?

@loginerror:
i checked the answer you posted.
from it, i understand that this problem occurs when re-running the application (However Windows by itself sometimes have problem with proper file return after closing application in which file was opened.")…so i restarted the pc and tried it only once (opening a previously created process)…and it didn’t work (see error message below [NOTE1], that came once then…and then the one above when i created a now process):
I checked the Computer Management and there are no items in the “Open Files” folder (like shown in the screenshot of Pablito).
However, i am not sure if i understand his answer correctly. He writes “Go to the server on which network share is created” → I am actually not sure what that means? Would i try to contact my local IT department and ask them to do that (>>> " Go to the server on which network share is created and check Computer Management to see if there is no active session on this file:") ?
Because i don’t know on which server the network share was created…

[NOTE1]
Restarted pc, open file from folder on desktop, got this error message:

19.4.2+Branch.master.Sha.e17a3bedca2a7da0d0b716b5f8f765d1d5ef1ddc

Common Language Runtime detected an invalid program.

Open Document Error: UiPath.Studio.Contracts.RecoverableException —> System.InvalidProgramException: Common Language Runtime detected an invalid program.
at UiPath.Studio.Shell.Services.DocumentService.ProcessNewDocument(IDocument document, IBeginAccessResult access)
at UiPath.Studio.Shell.Services.DocumentService.d__45.MoveNext() in D:\a\1\s\Studio\UiPath.Studio.Shell\Services\DocumentService.cs:line 376
— End of stack trace from previous location where exception was thrown —
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Studio.Core.Services.PersistableServiceBase`3.d__10.MoveNext() in D:\a\1\s\Studio\UiPath.Studio.Core\CommonServices\PersistableServiceBase.cs:line 0
— End of stack trace from previous location where exception was thrown —
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Studio.Shell.Services.OpenCloseCommandsService.d__20.MoveNext() in D:\a\1\s\Studio\UiPath.Studio.Shell\Services\OpenCloseCommandsService.cs:line 230
— End of inner exception stack trace —
at UiPath.Studio.Shell.Services.OpenCloseCommandsService.d__20.MoveNext() in D:\a\1\s\Studio\UiPath.Studio.Shell\Services\OpenCloseCommandsService.cs:line 235
— End of stack trace from previous location where exception was thrown —
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Studio.Shell.Services.OpenCloseCommandsService.d__14.MoveNext() in D:\a\1\s\Studio\UiPath.Studio.Shell\Services\OpenCloseCommandsService.cs:line 88
— End of stack trace from previous location where exception was thrown —
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Studio.Shell.ViewModels.MainWindowViewModel.d__206.MoveNext() in D:\a\1\s\Studio\UiPath.Studio.Shell\ViewModels\MainWindowViewModelCommands.cs:line 182, HResult -2146233088

Hey @MW23

If I understand it correctly, you might want to contact your IT department for them to have a look. If the session was not closed for that particular file, then it won’t show in your Computer Management, but rather in the Computer Management of the machine that is hosting the actual shared drive.

This is all assuming that the solution applies here. I would first try to copy your folder to another shared drive or to a different location and try to open it again.

So I tried the following:

  1. Copied the entire folder for the process on my Desktop and ran the process —> worked.
  2. Copied the entire folder for the process into another shared folder on the network → get the error message from my first post “Could not find part of the path…”
    → which would mean, if i understand correctly: the solution proposed is not it.

When I check the Output panel it shows me the following information:


Does that help in any way?

If it is the Enterprise edition, I would strongly advise you to contact our technical support for direct assistance.

It seems like the clue should be the actual error message, in this case stating that the path to the file cannot be properly parsed. This can be due to some characters it contains. Any chance you could post a full path to the file, either here or privately? I could then get it to our team to try to reproduce the issue.

Maybe if you map the folder differently it would work too?

Hi all,

This is indeed a new issue that came from some changes we made on how the robot (service) is handling files that are needed when Studio or UiRobot.exe -f cmd runs a flow.
Until now, the files were accessed by Studio (the user), but now they are accessed directly by the service (Local System).
Since only the user has share drive access, opening the project in Studio will work (as is done by the user) but the running part that is done through the robot (local system) won’t.

We have logged it and we are currently searching for a solution.

In the meantime, you can use the following temporary workaround (if this is allowed by your IT department):
You can give access rights to your MACHINE to the share like so:

  1. Right click on share folder > Properties
  2. Go to Security tab
  3. Click EDIT
  4. Click ADD
  5. Click on Object Types select Computers and then click OK
  6. Add your computer name in the "Enter the object names to select … " and then click Check names
  7. Click OK.

If everything is ok, it should look like this and running a project from Studio should now work :

For mapped drives, the situation is a little bit more complicated than this.
Beside the steps described above, you need to map your shared folder to a letter FOR THE SYSTEM ACCOUNT like so :

https://stackoverflow.com/a/4763324

Hope this helps,
-Andrei

7 Likes

Thanks, it worked…

1 Like

Thanks for your workaround, but I won’t be able to get this concession from my client’s IT dept. The robot service and workflows need to be able to access the same network resources/permissions as the user that is starting them. I look forward to a proper resolution soon. :slight_smile:

@andreiT
I’m experiencing the same problem here too “Access to path is denied; System.Exception”. I updated UiPath on my PC to 2019.4.2 and I am unable to use Google Drive File Stream for storing of my projects. I am unable to make the appropriate changes.

We are having the same problem, using a shared drive for our files and not being able to run it on the newest version. When will the fix be available?

Hi all,

We have a fix for this and we are going to include it in the next 19.4 (19.4.3) patch that we are targeting for next week (around Wednesday).

Thank you for your patience,
-Andrei

1 Like

Hi @icaruso,
Yes, we are still targeting 19.4.3 release for today. It should be out in a few hours.

-Andrei

1 Like

Is there already a new release ?

Yes, check out the download links below :

2019.4.3 FTS Patch Release Announcement

Changes: Studio & Robot bug fixes (full details in the release notes below)

Release notes: UiPath Release Notes

Please contact our support for the download links or request a Trial over here:
https://www.uipath.com/freetrial-or-community

1 Like

An alternative to @andreiT 's workarounds: You can re-install Studio in user-mode, if that is an option for you. This will effectively give Studio same network permissions as the user. @AllenC logically this sounds like your option, too (if 2019.4.3 isn’t the answer)

That has always been the requirement for Robot to access certain mapped network paths: https://robot.uipath.com/docs/using-mapped-network-drives

Note you will need the .msi installer to install in user mode, it’s not linked anywhere on the UiPath website, but this link might help: <link removed by Staff, sharing direct download links is not allowed>

Hey AndeiT , we are planning to migrate from 2018.2.3 to 2018.4.X(LTS) in July … what would you suggest we also want to wait and consider 2019.x LTS version which is going to come in october?

Which one should we take ideally - Need your opinion if possible technically supporting info for your decision

Hi @Syed_Pasha

The biggest ‘jump’ happens from any version pre 2018.3, due to the updated way of handling dependencies. From 2018.3, the dependencies are handled per project.

The positive side effect of that is that you can use new activity packages independently of your version of Studio. It is completely possible to use activity packages for the next stable Enterprise edition 2019.4 together with Studio 2018.4 :slight_smile:

I’m sure @andreiT will have more thoughts about it, but feel free to reach out to our documentation (Studio update, Robot update, Orchestrator update) and/or our technical support if needed.

1 Like

Hi @Syed_Pasha, glad you are using our product.

I’m afraid I do not have a definitive answer to you question, but I may be able to give you some insight and that could help your decision
First of all, as you know, any LTS version (like 18.4, 19.x) will have 2 years or product support. This means that if you install 18.4 now, you will still have at least 1.5 years or support.
However, if you think that you can use some functionality from the 19.x LTS release (check out our 2019 roadmap on youtube videos) then it might be worth the wait.
This is totally up to you and your needs.

On a personal note, what I would do is install 18.4 now (after some thorough testing) and run with it until next year, around this time.
After that, you will have the option to update it to 19.x LTS version.
The advantage with this approach is that you will have at least 6 months buffer time from the release data to you updating your system, so any bugs we might have missed would have been found and fixed by that time.
But this is all up to you and your organization ability to switch to a new version of UiPath Robot/Orch/Studio.

Hope this helps,
-Andrei

2 Likes

Thanks A lot for detailed explanation!

Hey AndreiT, one more quick question I am using 2012 R2 server in High Density- i have two robots running and accessing Excel - one process/robot trying to kill the application ? what will be the impact of this action on another robot…
when i tried it my first bot which is trying to kill excel is facing the error?