Unstable selectors on MS Teams

Hi Team,
I’m currently trying to automate on MS Teams.
But i’ve discovered this issue with the selectors.

E.g.
Here’s the Chat window on MS Teams, and i’m just trying to indicate the selector here
image

So on the first time where i indicate the selector (on UiExplorer), i’m able to obtain the selector(and its Valid)

But immediately, if i click on validate again, the same selector is Invalid.

Anyone has experienced this on MS Teams? Any advice would be helpful?

Hi.
Does it run properly regardless of validation?

Nope it always failed for almost all activites e.g. GetText, etc.

Did you try using wild card(asterik) on name tag?

@Yong_Kaivin - have you tried to change the Ui Explorer-> Ui Frameworks mode to “UI Automation” ? if not - pls try once. :slight_smile:

Yup, i’ve tried all different modes. Still the same, no changes.

@Yong_Kaivin - in my ms team chat poc to capture chat conversation and save it in my db…
have used selector like below

<wnd aaname='*Microsoft Teams*Window' app='teams.exe' cls='Chrome_WidgetWin_1' />
<ctrl name='*Microsoft Teams' role='document' />
<ctrl name='*chat content' role='grouping' />
<ctrl name='message list' role='DIV' />

for a specific user from my list -

<wnd aaname='*Microsoft Teams*Window' app='teams.exe' cls='Chrome_WidgetWin_1' />
<ctrl name='{{userName}}*Microsoft Teams' role='document' />
<ctrl name='{{userName}}*chat content' role='grouping' />
<ctrl name='message list' role='DIV' />

Hello Yong,
Check these videos to see how fast you can communicate with MS teams:

Thanks,
Cristian Negulescu