Invalid selectors after prior validation

I am working on my first UiPath process, and am encountering an ongoing issue. I am trying to work with a desktop application (ConnectWise Manage) and record a very simple process, where a screen is brought up in the application, a project number is searched for, then two fields are filled out on the project page. The selectors validate correctly when I first record and debug my workflow, but when I close and reopen the application, my selectors will no longer validate correctly.

The error I’m receiving is, “Cannot find the UI element corresponding to this selector.” I have read previous posts that I should try to remove any “idx” references, but the selectors will immediately stop validating when I try removing them. I’ve also tried adding anchors, but those fail validation as well when I reopen the program. I’ve tried using the web version of the app and using the web recorder, but am experiencing similar issues.

Here is the UI Explorer for one of these selectors (Invalid state after reopening “ConnectWise” application):

I’m using Studio Pro 2020.4.1 Community License. Any help that anyone could give would be so appreciated, I’ve been troubleshooting this for days and am not getting anywhere.

I was only able to post one image, so here is also the UI Explorer after I’ve corrected the invalidation by using the “Indicate Element” function:

@mintrowitz The Problem is with the selector property title
Replace it with wildcard Manage*

Hi Arpit, thanks so much for the response. I tried replacing with wildcards, but I’m still receiving the same error:

(This is a different selector than the one in my original post, but same error.)

Any other ideas of things I can try?