Unresolved Dependencies

I have not been able to install dependencies that are not from UiPath directly with my enterprise version 2019.10.2, then i upgraded to UiPath 2019.10.4 and i"m still getting the same result.

Please what do i do?

What is the error you get ?


1 Like

try updating all the available packages!

1 Like

When you trigger a job on the robot machine in case if it is connected to orchestrator, the robot looks for same version of the process in the %userprofile%/.nuget/packages folder if

  • It doesn’t finds there then downloads the same from the orchestrator package feed(configured in the web.config file).
  • If the same version of the package is available then it doesn’t download again.

Once the automation package is available, it reads the project.json file to check for the dependencies. It looks for all the dependencies in the below order-

  1. %userprofile%/.nuget/packages, if finds here then moves to next package, if not-
  2. Looks into the local feed (default- C:\Program Files (x86)\UiPath\Studio\Packages), if finds then installs the same and moved to next package, if not
  3. Looks for the package in the other configured package feeds in the NuGet.config file(C:\Program Files (x86)\UiPath\Studio\NuGet.Config and %appdata%\NuGet\NuGet.config). Please note if there are external package source configured in the config file then that should be accessible from that system else remove the same and make all the dependencies available locally.

Please visit the below link to get more insights on the same-


This is the error i get.
NU3004: Package ‘UiPathTeam.Excel.Extensions.Activities 1.0.7107.42453’ from source ‘https://gallery.uipath.com/api/v2’: signatureValidationMode is set to require, so packages are allowed only if signed by trusted signers; however, this package is unsigned.

I’ve done that but it doesn’t work still

This looks like a community package. Can you please place the package in the local feed and try. You can place the .nupkg in the folder <C:\Program Files (x86)\UiPath\Studio\Packages> and see if that helps. I have attached the.nupkg file for your reference.
uipathteam.excel.extensions.activities.1.0.7107.42453.nupkg (74.7 KB)


Hi @John_Dara,

You can turn off Signature Verification to fix the issue. You will need admin access to apply these changes.

Nuget.Config can be found in the following Path : C:\Program Files (x86)\UiPath\Studio\NuGet.Config

More Details here : Signing Packages



Thanks @Nithin_P and everyone, Its working now

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.