Failure to Install Project Dependencies: Feed is Invalid or Packages Were Removed During Installation

Hi All,

I’m having the following issue with installing project dependencies.

image

Context

I developed a project on my local machine using UiPath Studio 21.4.4 Community Edition and am wanting to transfer it to a virtual machine (VM) that has UiPath Studio 20.10.2 Enterprise Edition installed on it. I’ve copied the project folder and pasted it onto the VM. Upon opening the project on the VM, Studio attempts to restore dependencies until it runs into this error. As a side note, the VM does have proxy inspection.

Attempts

I’ve tried the following by tinkering with the packages but they did not resolve my issue:

  • Uninstalling and reinstalling from the package manager within Studio.

  • Copying the package files/folders from my local machine’s C:\Users\*\.nuget\packages folder and pasting them in the VM respective folder.

  • Changing and ensuring the feeds (https://www.myget.org/F/workflow/ and https://gallery.uipath.com/api/v2) exist in the Studio package manager package sources.

  • Manually installing packages from MyGet such as https://www.myget.org/feed/workflow/package/nuget/UiPath.Excel.Activities/2.11.0-preview and placing them in the folder referenced in the second bullet point or uploaded straight to Orchestrator.

  • Changing the dependencies/versions in the project.json file to lower versions.

My understanding is that the issue is likely local and due to the network configurations with the VM, so I’ve also tried to whitelist https://www.myget.org/F/workflow/ on the Windows Firewall by adding inbound/outbound rules, but had no luck. I can also download the package manually on the machine without issue.

Other Topics

Below are similar forum topics from where I found the suggestions that I’ve attempted.

(1) Error while downloading a package

(2) Feed is either invalid or required packages were removed while the current operation was in progress. Verify the package exists on the feed and try again

(3) Multiple attempts to download Package Failed

(4) Orchestrator Error: The feed, attempts to download the nupkg have failed - #11 by JKakumanu

(5) Project not be opened - #6 by jmy

(6) [Solved] the feed lists package but multiple attempts to download the nupkg have failed


Please let me know if you might have some knowledge on how to solve this issue or how I may workaround it.

Thanks!

Hi

Remove or delete the Project.JSON file and try opening the main xaml
Once after opening go to MANAGE PACKAGES and try to upgrade or downgrade the project dependencies version accordingly and see

cheers @kcroland

Welcome to the UiPath Forum @kcroland

This error generally happens when there are two login users having the same name of package.

You are using a VM, can you confirm there is no other login on that VM? if yes check and delete that process nuget package.

Hi @Palaniyappan,

Thanks for the suggestion! I removed the project.json file and opened the Main.xaml as suggested. The packages seemed to download fine, but when I tried to update them in the Package Manager to the needed versions. The error shows again.

I was able to update most of my packages (Uipath.Mail.Activities, Uipath.Excel.Activities, and Uipath.System.Activities) individually with the Uipath.UIAutomation.Activities being the only one that continues to prompt the error. I did notice this in earlier troubleshooting.

Thanks!

Remove that dependencies that are showing error and try installing the one that you manually download from below link, try a stable one.

Hi @rahulsharma,

There are multiple users on this VM, however the packages folder is within a shared E: drive rather than in specific user folders on the main C: drive. I did try to delete the package folder containing all the versions from the folder in the shared drive, but that did not resolve the error.

The issue also didn’t show when I had previously created a project on the VM itself, only when trying to move a project from my local machine. So I don’t believe it should be with the duplicate packages between users.

Thank you for the suggestion!

Hi @rahulsharma,

I had tried this before, but I may have placed the .nupkg file in the wrong location. Where Should I place it after manually downloading it?

Thanks!

Fine then let’s download and save it in local feed
Go to this folder and keep here the downloaded package file

%ProgramFiles%\UiPath\Studio\Packages

Cheers @kcroland

you can place in the C:\Users\YourUserName\.nuget\packages
that will load it directly

Also, just FYI, you can place the nupkg anywhere, just make sure that "anywhere is added as a source in the studio’s Manage Package section below, you can add customize folder there

Hi @Palaniyappan,

This is the folder that I needed and I’m able to find it now in my shared drive. I added a couple of the .nupkg files and all was well. I’m not sure what had happened, but I’m now getting a Nuspec file does not exist in package error.

I’ve tried deleting the package files that I added to get back to where I was, but the error still persists.

Thanks!

After a few trials of deleting and adding manually downloaded packages, I was able to work around this error. Within Studio’s package manager, I installed each package one by one and determined that the UiPath.Excel.Activities package was causing the “Nuspec file does not exist in package” error even though I confirmed it existed.

Although this allowed me to continue work on my project and issues were no longer found with the dependencies, I’d prefer that this be solved properly rather than a workaround to avoid future meetings with this error or something similar. I’m reaching out to my IT team to discuss potential firewall/proxy interference and will continue to search for a solution. For others that may run into this issue and are unable to solve with a workaround, I will try to keep this post updated with any findings!

Thank you to all who replied and offered suggestions!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.