Uninitialized Ui Node Error On Internet Explorer Objects

I am developing an RPA project that will work on internet explorer. I get “Uninitialized Ui Node” error whenever I want to reach any object on the page I opened. Have you ever experienced this error before?

Hi @erkanceylan

Please use Find Element inside the Attach Browser Activity.

1 Like

Hi @SathishCodes, i am already using find element inside the Attach Browser activity. There is something i missed.

Please check both the selectors are valid. Both Attach Browser and Find Element. I’ve faced this many times and the issue for me was because of the selector.

1 Like

Hi @erkanceylan
Can you check the selector in UiExplorer and check the properties on the right hand side

Ashwin S

1 Like

hi @AshwinS2

i checked the selectors and it’s all valid.

I found the solution. I have a different workflow called Login.xaml. After logging in that workflow, I was using the Browser object I received from that screen to be able to attach it to this page. I’m sure the browser object is not null, but I was getting the error that I explained in this topic. I tried to attach with the selector instead of being attach via the browser object and the problem was solved.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.