Uninitialized UI Node eroor

hi all!

so I am getting this error I tried a few different things but nothing helped so far I am getting the “Uninitialized UI Node” error! 19.10.0-beta.440+Branch.release-v2019.10.0.Sha.b53ca6e954b9d6809fd0f521e6fefeb65d823445

Source: Click Log Out System 1

Message: One or more errors occurred.

Exception Type: System.AggregateException

RemoteException wrapping System.AggregateException: One or more errors occurred. —> RemoteException wrapping System.Runtime.InteropServices.COMException: Uninitialized UI node.
at UiPath.UiBrowserClass.get_node()
at UiPath.Core.Browser.get_Element()
at UiPath.Core.Activities.Target.<>c__DisplayClass36_0.b__0()
at System.Threading.Tasks.Task.InnerInvoke()
at System.Threading.Tasks.Task.Execute()
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Thanks for helping!
Cheers!

I think you did not attach a browser window. Click the “indicate browser on screen” promt, and select the browser window. It should work then, as long as the “log out” is there.

1 Like

Hi @SSavickas

Great point but i used a variable as input so thats not a problem!

Cheers!

I would then check if the variable itself is not empty. Debug mode should work, or just do an If with a “is Nothing” clause.
Also, are you using the browser as an argument and pushing it between workflow files?

1 Like

Fine
Kindly reselect the element of that button with this click activity and try once
And also ensure that simulate click is enabled

Kindly try this and let know for any queries or clarification
Cheers @BjrnUitenbroek

1 Like

hi @Palaniyappan

thanks for helping again i fixed the problem but now i have another error again


and making it dynamic with a ‘*’ doesn’t work what do i do?

Cheers!!

Ensure once that when this xaml which clicks on logout button, is about to execute then that page must be available
That is we need to check the previous activity to the invoke woke file activity that called this xaml
Because when the bot tried to click on the log out button this browser window is not there that’s why throwing error

Kindly check that once and let know for any queries or clarification
Cheers @BjrnUitenbroek

1 Like

Thanks a lot mate!
So i checked nothing a problem the projects run on their own but when i run the main full project they fail?

Cheers

1 Like

Great so we need to check in the whole project and before to this log out xaml like whether it keeps the log out page visible while the process is executing

May I know what xaml or sequence of activities is Used before to this log out xaml
Cheers @BjrnUitenbroek

1 Like

Of course!


activity before system 1 close xaml

And again thanks a lot for all your help it means a lot!

1 Like

Check once in the xaml get datatable variable before to our log out xaml, has left the final step with page where we can log out
Else we need to include that only then the next xaml when searches for log out button and it’s window page it can execute those sequence of activities

Cheers @BjrnUitenbroek

1 Like

Checked :smile:
But now i am getting this error


this is i think the thing that causes everything!

1 Like

Ensure once the IN arguments of this xaml is given without null values
Cheers @BjrnUitenbroek

1 Like