UNICODE characters from csv to webapp not working

i am trying to write unicode(vietnamese) to webapplication but it is just generating those special characters into #@$%&(?

Please help!


while reading CSV you must set the encoding I guess.

Please check the following -

Karthik Byggari

HI karthik,

Thank you for the support,
Unfortunately it is not working for me somehow.

Give a Try copying the text to clip board and then paste into the webpage.

Karthik Byggari

in that case use SET TO CLIPBOARD activity and pass that string as input
–then use SEND HOT KEY Activity with key as ctrl+v which will paste that value directly

Cheers @rahul_gola

No luck, still the same, when i am copying and pasting its working, typing manually its working correctly but when typing with the type into activity it is not working.

1 Like

That’s why buddy suggest copy pasting
Did Set Clipboard activity and send hot key helped you on this
Cheers @rahul_gola

Maybe its getting issues due character encoding differences in the CSV file / Activities

In such cases a check e.g. with notepad++ of the csv file can help to check

  • for character set to use
  • encoding issues in the csv

then the read csv activity should be configured to the encoding set as applied in csv file

In case of corruption or Strange Character Blocks are already present on the csv a correction is to plan (manually, tool based)

Hi Palaniyappan,
thank you but i cannot use the set to clipboard activity as there are many other fields and i am using Datatable to itrate through.

So below is the input from csv, which is in the Vietnamese text.

Trại giam Đại Bình (thuộc Cục Cảnh sát quản lý trại giam, cơ sở giáo dục bắt buộc, trường giáo dưỡng - Bộ Công an) đóng tại xã Lộc Thành, huyện Bảo Lâm, tỉnh Lâm Đồng đã phát lệnh truy nã đối với Trần Văn Tuân (sinh năm 1984) trú tại xã Trường Trung, huyện Nông Cống, tỉnh Thanh Hóa về hành vi trốn khỏi nơi giam giữ.

and when i am using TYPE INTO ACTIVITY to type in Windows enrich text box which is on the CITRIX environment.

below is the output i am getting.

Tr?i giam Ð?i Bình (thu?c C?c C?nh sát qu?n lý tr?i giam, co s? giáo d?c b?t bu?c, tru?ng giáo du?ng - B? Công an) dóng t?i xã L?c Thành, huy?n B?o Lâm, t?nh Lâm Ð?ng dã phát l?nh truy nã d?i v?i Tr?n Van Tuân (sinh nam 1984) trú t?i xã Tru?ng Trung, huy?n Nông C?ng, t?nh Thanh Hóa v? hành vi tr?n kh?i noi giam gi?.

i have tried using windows-1258 supported character encoding by creating an variable too but still no luck.

Could you please suggest ?


I have Found a way. i have tried everythin even with the unicode windows-1258 it didnt worked in the native windows application, so i have used an remote desktop application which is on the same environment as the citrix. and it worked.

Thank you all for the support.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.