Unable to use MS Edge Extension

We are migrating our robots from Internet Explorer to MS Edge, but after installing the MS Edge Uipath Extension (from Microsoft Edge Addons), we noticed a red flag on Uipath icon and the message : The native part of the extension is not configured correctly.
Re-install the extension from UiPath Studio.

We tried also to install it from Uipath Studio and the message remains the same.

Please help us to solve this issue, thanks !!

Does your company have a group policy that prevents installation of extensions?

Hi Paul, yes, we have, but it was already changed to allow us to install the Extension. Is there any other adjustment to be made ?

Are you logged in with full administrator permissions when installing?

I was not, but we performed this test on another machine, installing it as admin, with the same result.

Seems like there has to be something blocking it. Antivirus?

@patricia.gozzo Can you please confirm that you are using UiPath Studio v21.10?
The Edge extension you have installed only works with UiPath Studio v21.10.

If you do have UiPath Studio v21.10, then it is mandatory to install the Edge extension using one of the methods described here:
Extension for Microsoft Edge (uipath.com)
This is needed to setup the native part of the extension - for which you are getting the error now.

If you have installed the Edge extension correctly, then check the following troubleshooting guides:

  1. Check if you have any Group Policy that interferes with the native part of the extension
    Edge Group Policies (uipath.com)

  2. Check if the ComSpec environment variable is correctly defined.
    This is an issue that affects the native part of the extension for Chrome/Edge
    Chrome Extension Troubleshooting (uipath.com)