Cannot communicate with UiPath Platform The native part of the extension is not configured correctly. - Edge

I’m unable to get UiPath working with Edge Web Automation. Tried reinstalling & restarting multiple times.


For now, can you check the following document?


Hi Yoichi,

Thank you for getting back to me. Yes I’ve read the document and checked that the extension was installed on my edge browser.

However, the “ChromeNativeMessaging.exe” is not running on my edge task manager. please advice


How about other items : group policy and ComSpec environment?


Do you have admin rights on your PC?

No I do not have admin access. This is my work laptop

Hi @WilfredNg

Open the Edge web browser and open extensions. Open the manage extensions. Check the UiPath browser installed. If not installed in edge browser, Click on the Get Extensions for Microsoft Edge and search for the UiPath and install the UiPath Browser Automation.

Hope it helps!!

OK, and how was the extension installed? Did you get it installed via the Tools menu in UiPath Studio, or was it installed during UiPath Studio installation?

When I tried to use the “Use Application/Browser” Activity and i selected the edge browser application it prompted me to install the extension even though it’s installed. I’ve tried installing through the edge browser extensions marketplace and through the prompt setup extensions when trying to use the activity. Both failed

Ok since it’s a work laptop there’s a couple of things you’ll need to check:

  1. Go to edge://policy in your browser, and look for the following policies, post a screenshot of it here
  • ExtensionInstallAllowlist
  • ExtensionInstallForcelist
  • NativeMessagingAllowlist


  1. How did you install UiPath Studio on your work laptop? Was it done by yourself without admin rights or by someone else with admin rigths?

I don’t see the - ExtensionInstallForceList & NativeMessagingAllowlist

  1. I installed UiPath myself. It didn’t require any escalation of admin rights. For UiPath Studio

Ok how about ExtensionInstallBlocklist, NativeMessagingBlocklist and NativeMessagingUserLevelHosts? Are they present?

Both of them are not present as well within the list.

Ok, one last thing to check - go to Start Menu → Event Viewer, then navigate to the Applications and Services Logs → Microsoft → Windows → AppLocker → EXE and DLL folder, example below.

Close your Edge browser, wait a few seconds then open it again. Once it’s opened, click Refresh on the right hand panel of Event Viewer, see if any Errors appear in the middle panel.

It did not showed anything unusual or an error message

Ok. So I think there’s no restriction on the extension being run in your environment, even if installed without admin rights.

Could you refer to the following steps to check the ComSpec environment variable to see if it’s properly set?

Studio - Microsoft Edge Extension Troubleshooting (

And finally, what happens if you try to install / reinstall the extension from the UiPath Studio → Tools menu?


I’m not able to access the environment variables as it requires admin privileges

I’ve installed the extension under current user is that okay?

Hmm not quite sure, because there might be other security policies applied on your PC that prevent the extension from functioning. Is it a possibility for you to find someone who can install UiPath Studio for you with admin rights? The installation wizard has an option (which is normally selected by default) to install the extension together with UiPath Studio.

Yeah I believe that there might be some security policies blocking the extension. Thanks!

@WilfredNg did you manage to get it working?