Unable to set up UIPath and Cyber Ark integration

Hi All,

Unable to set up UiPath and Cyber Ark integration. Used two solution approaches.

  1. I have installed UiPath credential proxy. But cloud URL is not reachable. I tried with both connected and disconnected credential proxy.

  2. I have used available CyberArk credential store as well. But because UiPath cloud is public URL and because of security protocols, its not working.

Can anyone please help regarding this to achieve this integration successfully. I am using UiPath studio 2021.10.

Regards,
rds

Last discussion I had with UiPath support on 7/18/2022 was that there was an issue with Orchestrator Cloud and the way it attempts to interface with CyberArk.

Bot tells Orchestrator it needs it’s credentials->Orchestrator reaches out to Cyberark and get the credentials->Cyberark passes the Credentials to Orchestrator->Orchestrator gives Credentials to the robot.
So the credentials would be being passed from Cyberark to Orchestrator externally.

I think the only way around this would be to switch your orchestrator to on-premise so that it doesn’t have to pass the credentials externally.

If anyone else has another solution besides switching to on-premise, I am all ears! :slight_smile:

yes. I have also created ticket with UiPath support team. Still that is in progress.
But we already switched from on-prem to Cloud long time back … doing reverse is again challenging.

What I got last update we need to upgrade our robot VM to 2023+ version to support disconnected credential proxy. But this is not working.

Is there any further update from UiPath on this topic. Has anyone completed Disconnected Proxy setup on UiPath automation cloud?

not yet. Ticket is still open.

@rds0511 Do you have any update?

We were finally able to setup Disconnected Proxy in our organisation