Unable to select the drop down values


We have a Java & Angular JS web application on which i am trying to automate customer creation process using uipath. however, i got into a situation where i am unable to select the values from the drop down list (Dynamically populated).

I have gone through various threads in this forum, however i could not see any post which could guide me step by step to overcome the problem.

Could anyone kindly guide me on how to read the select drop down list values.


Hi Harish,

Could you describe what behaviour you are currently getting? I have seen select Item go into a drop down and then not finalise the item.

You could always look at using a type into in the drop down to select the item? I know that some applications will not allow a certain number of characters so this may require some experiments first.

Any questions, let me know.


you can also use a click activity, and use simulate click property in the properties of the activity, then it should click the menu item in the dropdown using background automation, which gets around the dropdown problem

Hi @hareesh04,

can you check this post.


Hi @Djh,

Following your steps

  1. Use the click activity
  2. use simulate click in the properties.

I am able to simulate the dropdown. But the challenge is how to select the values from the dropdown.

Could you help me how to select the value from the dropdown.

Hi @jakelewis18,

Type Into is not working as the dropdown is not allowing to type the values.


Hi @hareesh04

if you follow these steps you should be good:

  • put a click activity down in studio
  • Click indicate on screen, UiPath studio will minimise and you will have the blue UiExplorer indicator hovering over elements
  • press F2 on your keyboard, this will give you a 3(?) second delay before picking your element. use this delay to drop the menu down so you can see the menu items, then wait for the blue indicator to appear again
  • click the menu item you want, using the blue indicator, which will set the selector for the menu item. studio should then put back up.
    -finally, in the properties of the click activity you have just made, check the box next to SimulateClick
    -reset the menu so it is not still visible, run the automation and you should see the dropdown menu item change to the one you selected.

I hope this helps!


Hello @Djh

Thank you very much for sparing time and helping me with the solutions.

I tried with the steps you have suggested and ran the sequence. YES, it was successful for the first time i ran it. Unfortunately, from the second time it started throwing me the error.

Below is the screenshot of the error for the same.


Could you help me to find the best possible solution for this scenario.

Thanks in Advance

can you show me the selector for the click activity?


Does anyone know how a work around if ‘Select Item’ activity is not supported for the drop down list & the item we want to select is an argument? E.G the item you select is dependent on what is called through from different workflows.

In our scenario we can not use send hot keys.


You could use a click activity to open up the drop down menus, then a click text activity, with a dynamic selector which includes an argument for the specific value fed in from elsewhere in the workflow.

If you are having issues clicking your menu item because you are having to scroll down the menus items to make your one visible before clicking, then try to use simulate click or send windows messages in the properties settings for the click text activity, which should allow it to click the item without it being visible

Hi @Djh ,

I want to say “Thank you very much”, your solution has helped to fix an issue which bother me 2 hours.

Following is what you have helped me!

The requirement is very simple, just choose a file type “Illustrator EPS (*.EPS)” from drop down

[Tried Methods]
I have tried 3 ways, but all failed:

  • Select Item Activity

  • Click Activity to activate the selection, then Click Activity to choose the file type

  • Send Hotkey Activity

When we manually choose the file type, the panel will also dynamically change based on the choosen, some options may be activated, like this:

The issue is even if the RPA has chosen the correct file type, the panel won’t change accordingly, like this:

[Your solution]
So I tried your solution, use 2 Click Activity,

  1. first Click Activity to activate the drop down

  2. second Click Activity to choose the file type, the most important is choose SimulateClick in the Properties panel

So it works! Thanks again!

Anyone who have the same issue, please try this!

Happy Automation!

1 Like

Great! I’m glad it helped - Happy automating!

perfect guidelines :ok_hand:. Thanks mate :star_struck: