Unable to run Process from Command Line

Trying to run a Process from Command Line using instructions from Arguments Description. When I use the command UiRobot -p StartJob_forTesting - the process doesn’t start and command prompt displays all the available command-line arguments.

This list is missing information about running the process as on UiPath web site

Using commands to execute a specified workflow works fine (like UiRobot -file "C:\UiPath\Project\Main.xaml").

The process is visible in the Robot Tray and can be successfully run using it.
Studio Version: 2018.2.6 Enterprise

Please advise why I can’t run the process and why Command-Line help doesn’t display information about running the processes


hello @V_R

can you try the below command

“C:\Program Files (x86)\UiPath Studio\UiRobot.exe”

first path is for Robot and second for File you want run


hello @Ajju

Thanks for your reply.
Yes, this method worked for me.

I have tried it earlier as I mentioned in the post

But I don’t want to use -file command because it just runs the XAML file. Instead, I want to use -process command because it executes a process in Orchestrator which is much more convenient.



check the below articles


I’m not sure what do you mean @Ajju

I reviewed the articles but the robot is already connected to Orchestrator. And processes can successfully be executed using Robot Tray and Orchestrator. But can’t be started from the command line using - process command.

Maybe I am missing something. Please specify what you meant.



I guess the reason is giving with Robot Version:

has not /p argument

with this version the /p Argument was introduced

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.