Unable to Publish the developed process

I am not getting any error while publishing but the publish process is remaining stuck at “building package” meanwhile producing ‘.dll’ files ( publishing a process not a library).
I have tested the automation there is no error or warning.

I have published multiple process in past but never came across such scenario. I am still able to publish the previously developed processes to orchestrator or a custom location.

The studio version I am using is “2023.10.0”

1 Like

Restart your machine and give a try
Make sure you have good Internet connectivity and disable if any firewall stops the action

Cheers @Maneesha_Maneesha

HI @Maneesha_Maneesha

  1. Can you check whether do you have permission to publish the process
  2. Restart the machine and try

Hi @Maneesha_Maneesha ,

Try re-sign in studio, re-open or restart the Studio or at the end machine restart might does work.

I already tried restarting the machine, re-connecting the studio and assistant, and creating a new process and then publishing but nothing worked.

Hi @Maneesha_Maneesha

Follow this Steps:

-Check Your Orchestrator Connection

  • Check Your Project Configuration
  • Check Dependencies
  • Check for Errors
  • Check Robot Permissions
  • Check Publish Folder
  • Log Files
  • UiPath Version Compatibility
  • Retry Publishing


The studio version I am using is ‘2023.10.0’ and the orchestrator’s is ‘2023.4’. So I believe this might be causing compatibility issue while publishing to orchestrator.

But I am not even able to publish locally.

On the other hand the project configuration, dependencies, error/warning etc. are fine.