Unable to publish to orchestrator - Issue occurs only with one project

One of the user is facing issue in publishing project to orchestrator.
Error: Publish of process project to Orchestrator failed. You are not authorized!
Issue is only with this particular project. But user is able to publish locally, create .nupkg file and upload directly to orchestrator.
User is able to publish other projects without any issues.

  • We checked the permissions - No issues.
  • File size is almost 20 MB.
  • We tried changing the version. Dint help too.
  • Studio is connected and licensed
    Any suggestions on what to check or what may be wrong?

Hi @Nira
just check
It can be resolved by giving your Robot user permissions to Publish the package…

Hope that resolves…Happy Learning !

Hi ! Thanks for the reply.
It is development environment. user belong to correct sec group and the group have permission to package.

Also as I mentioned, issue occurs only for 1 project.

Is it an onpremise orchestrator @Nira

Yes. It is on-premise orchestrator. V2021.
User have studio license.

are you using any libraries in this particular automation

Thanks for the message.
I see these dependencies.
Well I am not sure, if this was the question about. I can check with the user too.

Check the project folders and see if there’s a folder with a lot in it, typically it’s the screenshots folder. When your project gets too big it won’t publish properly.

Paul’s point was going to be my next point. I’ve also seen cases where… although the user is not authorized to create a library, if they use code from a library I’ve seen this issue occur.

One other check… is this stored in source control? Is it possible for another user to promote to Orch? If so… it may be rights related. Finally, check the Process version currently in Orch. Make sure you’re not trying to upload a json version that is lower than the version in Orch

Exactly. We tried to publish in our poc orch (Where admin have full control) and it was published as libraries.
So we will add permissions for libraries in “Roles” in the user environment.
Thank you very much @Chris_Bolin and all for the input.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.