Unable to locate packages - check compatibility

Hi all,

Perhaps this is common knowledge, but it took me quite some time to figure this out so even if this just helps a single person, I will consider this post a success.

First, I will list the specifications on my machine and then I will go into listing the symptoms I noticed in case the title of the post doesn’t capture the right audience.

I am using the Community edition of Studio that just got upgraded to 2021.10.3. I have this edition on my work laptop and my personal computer.

Symptom: I was looking for the Microsoft.Activities.Extensions package on my personal computer because I needed to utilize some of the dictionary functions that are associated with it, but I was unable to locate it in the manage packages area (however, it would show up on my work laptop). The Windows version and the .NET framework were the same for both machines.

I tried to manually get the package into the manage package area a couple different ways:

  1. Opened the .json file via notepad and added it (this technically worked, but, it was in red under the dependencies area and would not allow me to repair it, so this was essentially useless).
  2. Downloaded the package via the nuget.org site and attempted to insert it into a personal directory (this did not seem to work- perhaps I was doing it wrong)

Eventually, it led me to the following error:
NU1202: Package Microsoft.Activities.Extensions 2.0.6.9 is not compatible with net5.0-windows7.0(.NETCoreApp,Version=5.0)/win10-x64. Package Microsoft.Activities.Extensions 2.0.6.9 supports:
-net40 (.NETFramework, Version=4.0)
-net401 (.NETFramework, Version=4.0.1)
-net45 (.NETFramework, Version=4.5)

Note that, although I was searching for this particular package, there were other packages that were experiencing the same symptom (unavailable in Manage Packages area on one machine, but available in the other).

What I came to realize is, when you open a new project there are 3 new options that you need to pay attention to in the ‘compatibility’ drop down section: Windows - Legacy, Windows, and Cross-Platform

Apparently, if you choose the ‘Windows’ option, this is not compatible with some of the packages (hence the reason they do not appear in the manage packages area), so you must at least choose ‘Windows - Legacy’ (Note: I have not used the Cross-Platform option to know much about it at this time).

TL:DR; If you’re unable to find one of the packages in the ‘Manage Packages’ area, check to make sure you have selected the correct compatibility drop down when you started the project if you’re using the latest version of Studio (2021.10.3)

Cheers!

1 Like

Hello @amedina!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff