Unable to launch Power BI with Open Application Activity: Access Denied Exception

Hey guys,

Does anyone know what kind of exception this is? It’s my first time to come across it. I can launch all my other applications normally (as tested) however when I attach this application to the Open Application activity, it gives me a runtime error:

Would appreciate if you have any solutions to this.
I have yet to try other methods like using click activity or hotkeys, but I’d like to know if there is a more convenient solution to this if I ever come across this again in the future.


Hi @strqsr,
If the ‘open application’ activity is getting failed just do it by this way
make opening this as .bat file and open bat file through UiPath



If you are able to open the application manually, then it should open in the uipath also. Make sure you have the folder permissions for the exe file of power BI

Hi! I can open the file manually and run it, which is why I’m stumped cause I’m the admin and have full access to all folders and application. It didn’t work when I tried desktop recorder as well which lead me to think if I should use hotkeys and manually type the name into the search bar, but it’s not as efficient as using the Open Application

@baisilgee Hi, not the sure how to do that via UiPath, is this what you mean? Running a .bat file using start process

Can you try to open the path and check the exe located in it @strqsr

C:\Program Files\WindowsApps\…

I installed it from Microsoft Store as a Power BI Desktop, so it doesn’t appear to have a path, or at least not one that I can find and I’ve looked.

Is there a difference from Microsoft Store and the one online? @HareeshMR

Nevermind, I think I found it: C:\Program Files\WindowsApps\Microsoft.MicrosoftPowerBIDesktop_2.72.5561.0_x64__8wekyb3d8bbwe

This is what it gave me

Yes i think


In open application activity instead of using the indicate window just provide the path of the application in fileName property.

Hi, I’d still have to indicate the window if not there will be an error as a selector is provided.


Can you try again?

When I’m trying to open the folder, it is giving me the below error, can you confirm if you are able to open that folder @strqsr


Hi, I’ve solved the issue, it was because instead of downloading the exe file, I downloaded it from the Microsoft Store so UiPath doesn’t have the permission to launch it. Thank you for the help!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.