Unable to get a new access token using the "Uipath Connector Guide"

Hello All,

Im currently trying to get a new access token using the following guide: https://postman.uipath.rocks/. I have imported the collection into postman and recreated the necessary steps to get the access token so I can connect to my Uipath Automation Cloud. I created the enviroment with the needed values and created an external Application in the Automation Cloud. Everytime I try to get the token i get the same Error. Does anyone have a better guide or an idea why this might be the case?

I know you can use the old authorication by calling https://account.uipath.com/oauth/token? but I need to get the Token using oAuth2.0.

Also could someone explain to me where I can find the onPrem URL and if it is needed for this Authorization? The same goes for the RedirectURL when creating an external Application in the Automisation Cloud, what do I put in if I want to access my jobs?

Thank you in advance.

My Parameters used in the collection:

My Enviroment for the collection:

The Redirect URL for the external Application in the Automisation Cloud:

Hi @or.tamer ,

  1. For Om-Prem the end points you need to use are different.
    Auth URL - https://{Orchestrator_URL}/identity/connect/authorize
    Token URL - https://{Orchestrator_URL}/identity/connect/token
    and also Grant type - Authorization code supports only user scope
    if you are looking to add other scopes then use Client_Credentials grant type
  2. Redirect URL is the Callback URL that you see in Postman. Please copy the same and paste it in Orchestrator Redirect URL field


Hello @Anil_G,

Thank you for answering. I am not using On-Prem, I only have the Community License. Do you know the fitting URL for the Authorization or Token URL? When I use the URL you gave me I just get the following message instead of the authorication Token.

Thank you in advance

Hi @or.tamer ,

Following are for cloud …

Auth : UiPath
Toke : https://cloud.uipath.com/identity_/connect/token

Please try and happy automation


Hello @Anil_G,

I have been trying with your given information but I am still unable to connect to Orchestrator. I have used the following parameters as you have given me:

I get this error Code if I try to get the Access Token:

The Error has this URL.

I believe that I have to change something about the Auth URL but after trying multiple Times im unsure what I am doing wrong. Do you know what I have to change? Is it also possible that you cannot get an access token with Postman if you only have the Community License? I have been testing out so many possibilities but none were able to get me the token.

Thank you in advance

Hi @or.tamer ,

Please remove all the scopes from your application first. Authorization code type will allow only user scope. That might be the reason as I am able to get the details using the same from community edition. To start please give only once scope n user as well as below to check.


Hi @Anil_G ,

I have removed all Scopes like you said and only added a user scope. I still get the same error and have no idea why. Do you have any other idea?

Thank you very much for helping me here, I still cannot figure out why it won’t function.

Hi @or.tamer - Your Auth URL is incorrect here. You are missing /identity_/. I got the same error “Orchestrator is not enabled for this tenant” when I removed this value. Please add the Auth URL correctly.

Correct URL,

Hello @JithinKP ,

Thank you for answering. I still get the same error I had at the beginning when I am still signed in Orchestrator in another tab. If I log out however, the tab goes from https: //cloud.uipath.com/identity_/web/ to suddenly change to https://localhost. Any Idea why? I did set the redirect URL in the cloud to https://oauth.pstmn.io/v1/browser-callback.

Thank you in advance for answering.

I have finally figured out why it didn’t work: I forgot to remove the Application Scopes in postman which I did not need. I still have a question: When I want the access token the tab still requires me to log in so i can get the access token. Is it possible to get the token without needing to log in every time?

Thank you all for helping me.


Hi @or.tamer ,

good to see this. Even I corrected and re checked it. Th UI will come only first time. For the subsequent ones a refresh token will be generated. For more info please feel free to check Using OAuth for External Apps


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.