Unable to Extract Datatable using Data extraction from Desktop application

Hi Team,

This is a Java based application, where I need to extract this table, But Data scraping is not supporting & I have also tried with Get text activity it indicating the entire table.
Screenshot attached for reference.

Kindly, provide your suggestion for the below scenario.

Thank you in advance.

Hi @nithya

First of all, you need to try to solve the problem of indicating entire table.
When you are indicating an element in an application on screen,
UiPath provide three methods , you can simply press F14 to toggle between them
or use UI Explore like below.
Once you successfully indicated a specific cell,
I believe you can go on by yourself according to the rules of those selectors.

Hi @wusiyangjia

Thanks for your response,

I already tried the approach you have mentioned. Still, it is indicating entire table.

Hi @nithya

I wonder if you have installed the Java extension of UiPath.

@wusiyangjia ,

Yes, Java extension is installed. Except this table I am able to indicate every element.

Only this table its indicating entire table.

What is the selector of the table (element that gets highlighted)? Have you tried using the latest UiAutomation.Activities package available? If so, when using 22.4, what is the fullClassName property of the indicated element (can be seen in Property Explorer panel inside UiExplorer).

Yes, I am using the latest package version.
Please, find the selector screenshot.


It seems to be an SWT-based app that we automate using native technologies (ctrl / uia type tags). If switching the technology with F4 doesn’t improve accessibility, then you could try Computer Vision activities. The Java extension will not help you in this case since it is designed for AWT-based apps.