Not able to get table data from desktop application

Hi I need to extract the table data from desktop application, but when i tried it is taking the whole page and there are no selector and when i tried screen scrapping the text is not giving properly

Welcome to the UiPath community,

Are you using the “Extract Structured Data” activity?
Please provide us with selector and selector status

I tried using that but it is telling that not a table element and there is no proper selector and when i hover it is taling whole table

Ok, There are some tables on desktop apps that have no selectors for rows and columns
in this case, usually I try to get full text for the table OR
use send hotkey (down) to move on rows and get your action on the rows

Actually from screen scrapping i am able to get some little part of the data, for some cells there is some color in the background cell because of that i am not able to get that data, but i need that data also

Hi @gg00857020 ,

kindly share me you tried process step snapshot for (how to indicate the elements snapshots share me).

This is the table i am looking. I tried screen scrapping able to get the all cell details except the cells


Your process to get all the data of the screen correct,

first method;

1.First indicate the 0th column of A4 element (example : 0th row of A4 and Next indicate the 1st row of the A4 element),
2. that’s all you can get the all the rows of the data’s

second method;

1,indicate the 0th column of A4 element and next indicate the 1st column of the A4 element)

I guess this two type of methods any one it will be use of your required process.

Actually I am not able to point out the cells and it is pointing the whole table, actually that table contain other column and able to get the from those columns when used screen scraping. because of the color background not able to get data from these cells

will there be any other option when we don’t have selector’s in the table data in desktop applications