Unable to detect selector in IBM Lotus Notes

selector
uiexplorer
lotus_notes

#1

Well, inside of my workspace in IBM Lotus Notes I want to double click the following mail box:

I’m trying to use a double click activity and the following selector:

Well, and the selector is simply not found. I have tried everything.

In the selector, when I click on “Attach to Live Element” and select the mail box icon, then I receive the following error message: “Could not attach to live element.”.
And if I click on “Open in UiExplorer”, then I get the following error: “Cannot find the UI element corresponding to this selector”.

I also tried to use other activities, namely the “Get Text” to get the text of the text that appears in the icon, but once again there is some problem with the selector.

I also tried to choose a “ClippingRegion”, but without any success.

So how is it possible then to use UiPath within IBM Lotus Notes ?


#2

Hi jcab, what I would suggest, is:
Use the activity ‘Click text’, type e.g. “Noeminha Bot” in the text field. Now, for ‘indicate on screen’, choose the whole workspace instead of just your particular mail box (so “Noeminha Bot(…)” would be missing in the selector).
Then change the ClickType to CLICK_DOUBLE in the Properties.
It worked for me, so I hope this may help.


#3

I already tried that, without any success.

I managed to double click the mailbox with the activity “Double Click Image”.

And this was only the first and easiest step. Let’s see the next steps…


#4

Are you certain that your automation opens this Lotus window correctly and looks for the text AFTER the window is open? Have you checked whether any text can be recognized? You may try to make some test with ‘Text exists’ activity (for e.g. “Noeminha Bot”), and then e.g. ‘Write line’ “Text exists” in ‘If’ activity when this text is detected. Let me know if you want more details.


#5

My selector for ‘Click Text’ was the same as yours, but without the Attributes ‘Geral’ and ‘Noemina Bot’.


#6

Well, I didn’t manage it your way and I don’t want to bother anymore with that, as I solved that issue with the click image.

Now I’m having another problem:

I want to search in my inbox.
So I first click click where the left red arrow points to, and immediately after on the word “Inbox”:

I’m able to click where the left arrow points to with a click activity. But I’m unable to click afterwards on “Inbox”.
I’ve tried it with a click activity, I’ve tried with click image activity, and with click text activity (I’ve also tried to use the get text activity and printing the text, and the text is empty). And none of them words.

Any ideas?


#7

Is ‘Inbox’ always highlighted as a default option just after you open the menu? Have you tried playing with ‘send hotkey’ activity? If this line is always highlighted, simply choose ‘Enter’.
Also, the letter ‘i’ in ‘Inbox’ is underlined, so when you type it, it should highlight this particular option after the menu is open.